No certificate

Please I installed it step by step and evry thing is ok till step 4 Generate Letsencrypt SSL Certificate

I didnt have /etc/letsencrypt/live but /etc/letsencrypt/. under this directory I only have 5 others directory (account,csr,keys, re newals; renewal-hooks).

Please help me to fix this. Excuse me for my bad english.

thank you

Did you tried to launch this command?

/usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh

Hi thanks,
I lauched it for the first time :it seems ok.

but for the second time when I lauch it, I get this message:

> *-------------------------------------------------------------------------*
> *This script will:*
> *- Need a working DNS record pointing to this machine(for domain meet.hakase-labs.io)*
> *- Download certbot-auto from https://dl.eff.org to /usr/local/sbin*
> *- Install additional dependencies in order to request Let’s Encrypt certificate*
> *- If running with jetty serving web content, will stop Jitsi Videobridge*
> *- Configure and reload nginx or apache2, whichever is used*
> 
> *You need to agree to the ACME server's Subscriber Agreement (https://letsencrypt.org/documents/LE-SA-v1.1.1-August-1-2016.pdf) *
> *by providing an email address for important account notifications*
> *Enter your email and press [ENTER]: samba.tounsi@yahoo.fr*
> *Saving debug log to /var/log/letsencrypt/letsencrypt.log*
> *Plugins selected: Authenticator webroot, Installer None*
> *Obtaining a new certificate*
> *Performing the following challenges:*
> *http-01 challenge for meet.hakase-labs.io*
> *Using the webroot path /usr/share/jitsi-meet for all unmatched domains.*
> *Waiting for verification...*
> ***Challenge failed for domain meet.hakase-labs.io***
> *http-01 challenge for meet.hakase-labs.io*
> *Cleaning up challenges*
> *Some challenges have failed.*
> 
> *IMPORTANT NOTES:*
> * - The following errors were reported by the server:*
> 
> *   Domain: meet.hakase-labs.io*
> *   Type:   dns*
> *   Detail: DNS problem: NXDOMAIN looking up A for meet.hakase-labs.io*
> *   - check that a DNS record exists for this domain*

thank you in advance

It looks like you forgot (as I did) to make an entry in your DNS system that points to the IP of the Jitsi server. You should go to the system where your DNS records are managed, add an A record with the value ‘meet.hakase-labs.io’ that points to the ip of the sever where you’ve installed Jitsi.

thank you very much for your reply,
but I installed Jisti behind an ADSL connexion and my IP address is private 192.168.1.5.

The Jisti application is installed on this IP address ie 192.168.1.5.

For DNS I dont know who manage it in our zone.

Please I don’t if I understand very well. but I still need your help because I am very newbie in jisti.

thank you Arnold, thank you for all

If you’re using jitsi ONLY inside your network I higly suggest to simply share and install the certificate in every computer that need to connect as a trusted certificate, doing this you’re safer from outside.

Otherwise you should check your router configuration if it support a dynamic dns provider and setup if (hoping in the list there’s a free one) and adding the port forwarding in the router and many other stuff that could expose your pc or network to outside attacks, I sincerely not advise doing so if it’s your pc and not a dedicated machine.

Thank you in advance,
I installed Jitsi in a machine inside my lan (with a private addresses like 192.168.1.* ). For the visioconference I want to be accessed from outside.
My default gateway is a Dlink box(192.168.1.1) which has a dhcp server, and other options.
But I didn’t understand if the task that you said must be done to this box or I have to contact my ISP.

Thank you

Dear all,
I think that my problem hasn’t solution. I navigated throw Internet and I met always with the same problem: nobody can solve this issue: no certificate. So I am planing to uninstall jitsi and replace it with another solution like google hangout or webex of cisco etc…
So I have 2 questions:

  1. How to uninstall jisti properly and avoid thus to have conflict between the dependencies of Jisti with other application in the future
  2. Which one of these solutions is most suitable and usefull to my situation(making some courses remotely for twenty participants or twenty five simultaneouosly)

Thank you in advance.

Depends on the router, you shoud expose your PC to external networks and this lead a lot to your network security. I’d advise to not do it. Anyway it’s done as I wrote in the previous posts. You should obviously set a static IP for your PC.

Simply run next command:

apt-get purge jigasi jitsi-meet jitsi-meet-web-config jitsi-meet-prosody jitsi-meet-turnserver jitsi-meet-web jicofo jitsi-videobridge2