No certificate present in SSL/TLS configuration for https port 5281

Hi All,

I have installed Jitsi meet by following https://jitsi.github.io/handbook/docs/devops-guide/devops-guide-quickstart

After the installation, the jitsi meet conference worked fine

later on I have switched to token authentication by following the https://github.com/jitsi/lib-jitsi-meet/blob/master/doc/tokens.md

After enabling token authentication I’m not able to host meeting the interface freezes and it is not showing the authentication window.

The browser console showing the following error

Strophe: request id 6.4 error 504 happened

The network tab throwing 504 error fo http-bind call

I have checked the prosody logs and the prosody log showing No certificate present in SSL/TLS configuration for https port 5281 at the time of startup

I have checked too many posts on this topic and tried all the solutions, unfortunately, I’m not able to solve it.

The webrtc clients connect to nginx first using https (with the tls certificate for your site) then nginx proxies to prosody using bosh on the uncrypted port, 5280. Port 5281 is never used by jitsi-meet.
So it’s not the reason for your problem.
You have to search in your prosody host configuration or whatever, not port 5281.

BTW if you want to get rid of this message, uncomment the https_ports line in the prosody config file to set it to an empty list, Prosody will stop to try to listen to port 5281 - but it will not fix your problem.

Thank you for your response.

Now I got the reason behind the port warning. Do you know how I can fix the other issues because there is no information available in the prosody logs and the browser continuously throwing the 504 gateway timeout issue for http-bind call Also the meeting interface is not responding.

Well I replied about the title of your first post - as I have never encountered your situation (i don’t use token authentication) I can’t hope to speculate with the little information you give; the gateway timeout suggest that your workstation tries to connect to prosody to authenticate and prosody don’t reply, but a good reason why is not obvious. Maybe providing the prosody config file and log could help to help you.

Thank you for your support. I have solved this issue by reinstalling the Jitsi instance. Still, I’m not sure is the issue in prosody or it is in the different component.