No audio while hosting the meeting

I have freshly configured Jitsi over Ubuntu 18.04 and it is having audio issue. participants are not able to talk each other.
Here is prosody.cfg.lua file

plugin_paths = { “/usr/share/jitsi-meet/prosody-plugins/” }

– domain mapper options, must at least have domain base set to use the mapper
muc_mapper_domain_base = “meet.in.workspaces.proc.jumio.local”;

external_service_secret = “7PDsDb5P0c19HbCC”;
external_services = {
{ type = “stun”, host = “meet.in.workspaces.proc.jumio.local”, port = 3478 },
{ type = “turn”, host = “meet.in.workspaces.proc.jumio.local”, port = 3478, transport = “udp”, secret = true, ttl = 86400, algorithm = “turn” },
{ type = “turns”, host = “meet.in.workspaces.proc.jumio.local”, port = 5349, transport = “tcp”, secret = true, ttl = 86400, algorithm = “turn” }
};

cross_domain_bosh = false;
consider_bosh_secure = true;
– https_ports = { }; – Remove this line to prevent listening on port 5284

Mozilla SSL Configuration Generator
ssl = {
protocol = “tlsv1_2+”;
ciphers = “ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384”
}

VirtualHost “meet.in.workspaces.proc.jumio.local”
– enabled = false – Remove this line to enable this host
authentication = “cyrus”
– Properties below are modified by jitsi-meet-tokens package config
– and authentication above is switched to “token”
–app_id=“example_app_id”
–app_secret=“example_app_secret”
– Assign this host a certificate for TLS, otherwise it would use the one
– set in the global section (if any).
– Note that old-style SSL on port 5223 only supports one certificate, and will always
– use the global one.
ssl = {
key = “/etc/prosody/certs/meet.in.workspaces.proc.jumio.local.key”;
certificate = “/etc/prosody/certs/meet.in.workspaces.proc.jumio.local.crt”;
}

cyrus_application_name = "xmpp"
allow_unencrypted_plain_auth = true

speakerstats_component = "speakerstats.meet.in.workspaces.proc.jumio.local"
conference_duration_component = "conferenceduration.meet.in.workspaces.proc.jumio.local"
-- we need bosh
modules_enabled = {
    "bosh";
    "pubsub";
    "ping"; -- Enable mod_ping
    "speakerstats";
    "external_services";
    "conference_duration";
    "muc_lobby_rooms";
}
c2s_require_encryption = false
lobby_muc = "lobby.meet.in.workspaces.proc.jumio.local"
main_muc = "conference.meet.in.workspaces.proc.jumio.local"
-- muc_lobby_whitelist = { "recorder.meet.in.workspaces.proc.jumio.local" } -- Here we can whitelist jibri to enter lobby enabled rooms

Component “conference.meet.in.workspaces.proc.jumio.local” “muc”
storage = “none”
modules_enabled = {
“muc_meeting_id”;
“muc_domain_mapper”;
–“token_verification”;
}
admins = { “focus@auth.meet.in.workspaces.proc.jumio.local” }
muc_room_locking = false
muc_room_default_public_jids = true

– internal muc component
Component “internal.auth.meet.in.workspaces.proc.jumio.local” “muc”
storage = “none”
modules_enabled = {
“ping”;
}
admins = { “focus@auth.meet.in.workspaces.proc.jumio.local”, “jvb@auth.meet.in.workspaces.proc.jumio.local” }
muc_room_locking = false
muc_room_default_public_jids = true

VirtualHost “auth.meet.in.workspaces.proc.jumio.local”
ssl = {
key = “/etc/prosody/certs/auth.meet.in.workspaces.proc.jumio.local.key”;
certificate = “/etc/prosody/certs/auth.meet.in.workspaces.proc.jumio.local.crt”;
}
authentication = “internal_hashed”

– Proxy to jicofo’s user JID, so that it doesn’t have to register as a component.
Component “focus.meet.in.workspaces.proc.jumio.local” “client_proxy”
target_address = “focus@auth.meet.in.workspaces.proc.jumio.local”

Component “speakerstats.meet.in.workspaces.proc.jumio.local” “speakerstats_component”
muc_component = “conference.meet.in.workspaces.proc.jumio.local”

Component “conferenceduration.meet.in.workspaces.proc.jumio.local” “conference_duration_component”
muc_component = “conference.meet.in.workspaces.proc.jumio.local”

Component “lobby.meet.in.workspaces.proc.jumio.local” “muc”
storage = “none”
restrict_room_creation = true
muc_room_locking = false
muc_room_default_public_jids = true

VirtualHost “guest.meet.in.workspaces.proc.jumio.local”
authentication = “anonymous”
modules_enabled = {
“turncredentials”;
}
c2s_require_encryption = false

My first suspicion is that this has something to do with your authentication. Can you try taking out the authentication and see if things work?

@Freddie Thanks for prompt reply.
Authentication is working fine because I’m successfully able to host the meeting using my domain credentials and my teammates are able to join it but only issue is audio. they are not able to talk.
while I’m trying to change the microphone or speaker it is saying "Failed to access your microphone, Cannot use microphone for an unknown reason. Error: The queue has been stopped.

You think authentication is working fine, but if audio streams are not going through, authentication could be the culprit. Again, temporarily remove authentication and check - it’s a quick and easy move to narrow down the possibilities.

After openining port 10000 audio is working fine.