No audio output - ALSA


#1

Hi,

When using pulseaudio I used to force the audio device using env variables, and both firefox and chromium were fine with that.
On computers without pulseaudio however, using regular plain ALSA, the only thing that works is using the default audio output. In both firefox and chromium the settings menu either doesn’t allow to select devices at all (greyed out) or allows only one option : default. For some reason in chromium choosing the microphone does work fine, but not the speakers / usb headset.

Now on chromium there is an option to chose the audio device : chromium --alsa-output-device=“hw:2,0”
With that things like YouTube work fine and are playing in the headset, but jitsi stays silent with absolutely no errors.
Another option is configuring the .asoundrc file to play through the headset before starting firefox / chromium but in that case again, YouTube works fine but jitsi comes out very choppy, more or less as if I was talking on a mobile phone in the middle of nowhere.

So after hours of struggling, tests, tries and research I still haven’t found a way to get jitsi meet (either the public instance or our private server) to work with my headset, I end up having to use the android application instead wich ins’t nearly as practical.
Any tips on things I might have missed ? Firefox or chromium I don’t really care at this point, any solution to get my headset to work would be great, I need my hands back.

Thanks


#2

Whe using PulseAudio, can you select the device with pavucontrol instead?


#3

I don’t know, maybe, but my issue isn’t with pulseaudio wich I no longer have, it’s when using ALSA.


#4

Firefox dropped support for plain ALSA some time ago: https://bugzilla.mozilla.org/show_bug.cgi?id=1345661 So you are left with Chrome alone. Don’t you see your headset in the device selection panel? (without passing any device ID, that is).


#5

That’s not true, Firefox does support ASLA just fine, they just don’t ship it in their binary packages.

Nope, in the device selection the microphone can be selected just fine, I get a list. But the output has only one element in chrome : Default. In Firefox the menu itself is disabled saying “Permission not granted”, but apparently that’s in purpose according to the github issue, that’s why I installed chromium.


#6

Here’s a screenshot of the settings panel if that helps :
settings


#7

Oh, TIL!

Hum. I’m not sure how to help you here. We don’t do wnything other than asking the browser to use a device from the list, the rest is up to the browser really.

Can you use this test page to check if you get the same problem there? https://webrtc.github.io/samples/src/content/devices/input-output/


#8

I learned that the hard way, I lost audio for a few days when they dropped alsa by default :frowning:

So I tried your link but I can’t get it to work. There’s 9 microphones in the list, none of them seems to do anything, and only one speaker in output.
It’s really strange, everything works fine except jitsi, I guess it doesn’t play audio the same way as HTML5 does.


#9

The link is some generic WebRTC test, so if that doesn’t work, Jitsi Meet won’t work either. Sorry about that, I don’t know what else you could try, other than going back to PulseAudio, but I assume that’s not an option for you.


#10

That’s really strange, looking at WebRTC tests this one works fine : https://webrtc.github.io/samples/src/content/devices/multi/
But the one just before this one, that you already linked, doesn’t do anything.
There must be something weird with WebRTC output only for some reason. Who knew getting the microphone to work would be the easy part !