No Audio, No Video

Hi.
I Configured Jitsi Meet server successfully on my own domain and server and created a room. But there is no audio or video even when their camera and microphone is open and all permissions allowed.

Have you followed the advanced section in https://jitsi.org/qi?

1 Like

I Followed instructions and Everything working fine now.
Thank you!

do you need the actual ip address where the <Internal.IP.Address> is and public address?

Hi there,

I have the same problem - I followed the guide on Self-Hosting Guide - Debian/Ubuntu server · Jitsi Meet Handbook but in the end there is no video or audio… Website works just fine, everything looks very nice. But when I join a conference, there is no audio or video and if I open the same conference on various devices, there seems to be no connection, nobody can see each other (even not in the participants list). I tried tabs, android app (loads forever), different laptops and browsers (Chrome, Edge, Firefox) but nothing works.

When I stop jitsi-videobridge2 or jicofo, nothing happens on the end devices, only when I restart prosody there is a message that the connection has been lost to the conference (in German, I’m using a German server). What could I do?

Maybe you can help, I wopuld appreaciate that very much!

Check your firewall. Make sure all required ports are open and accessible. Check port 10000/udp especially - make sure it’s open and properly forwarded, if behind a NAT.

I am pretty sure all ports are open and accessible in the firewall but I cannot confirm this as per “netstat -tulpn” there are a lot of services listening on my server, but nothing there listens to port 10000/udp…

There is one thing that puzzles me a bit… I do not have (or I am not able) to put in a username… there seems to be no authentication at all… how would that be handled? Do I need to specify something in a file somewhere?

Try confirming

Hi there, I can confirm:

sudo ngrep -q ‘is accessable’ udp port 10000
interface: eno3 (51.77.64.0/255.255.255.0)
filter: ( udp port 10000 ) and ((ip || ip6) || (vlan && (ip || ip6)))
match: is accessable

U 88.130.56.202:1295 → 51.77.64.166:10000 #1
yes, it is accessable.

When I try to connect to a jitsi meeting, this logger does not show any new lines or so…

Hi there, I also tried the solution of this Thread but it did not help, although the brackets were also missing in my case. Can I try some other version of jitsi and if yes, how would I do this?

That one is for jibri which is another case.

You can debug this with opening in chrome “chrome://webrtc-internals” before joining the meeting.
Open 3 tabs, then in webrtc-internals find the tab which doesn’t have stun listed as iceServers, then find the first setRemoteDescription, expand it, what do you see?
Is there only the private IP address of the bridge?

I had to download Chrome first, I have the best experiences with Firefox (also on meet.jit.si). But I cannot find the section requested, this is my output in Chrome:

Yep, that output changes after you open the 3 tabs. You should see 6 more tabs on the page next to getUserMedia one.

Hm, there are no more tabs that those three…

I also found something in the log now (which was empty in previous installations, I just tried it again today):

JVB 2021-09-01 18:56:36.140 WARNING: [361] [hostname=localhost id=shard] MucClient$1.connectionClosedOnError#277: Closed on error:
org.jivesoftware.smack.XMPPException$StreamErrorException: undefined-condition You can read more about the meaning of this stream error at Extensible Messaging and Presence Protocol (XMPP): Core
stream:errorNo stream features to proceed with</stream:error>
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1064)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPConnection.java:1000)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:1016)
at java.base/java.lang.Thread.run(Thread.java:829)
JVB 2021-09-01 18:56:38.884 INFO: [21] HealthChecker.run#171: Performed a successful health check in PT0.000011S. Sticky failure: false
JVB 2021-09-01 18:56:38.900 WARNING: [23] [hostname=localhost id=shard] MucClient.setPresenceExtensions#420: Cannot set presence extension: not connected.

I found soime very very long thread on github relating to that but its from a year ago and does not seem to solve anything…

Also, to be more clear, on this server there are a few services running. Most prominently an apache2 webserver (with letsencrypt certs) and a teamspeak server. Sometimes I have a Minecraft server running as well but its currently disabled (as I thought it might get in conflict with the java based jitsi). The server also acts as Mailserver for our community and has a Nextcloud on it (but thats only part of the normal website stuff)

It is not possible.
Here I opened webrtc-internals and 3 tabs on meet.jit.si and it looks like this.

And here is the bridge internal and external address as reported:

On meet.jit.si I get the same result that you do, but on the server I installed jitsi on, its not like that.

I think there is a deeper problem to that, some service not running properly, not connecting to the other services properly… on meet.jit.si I also have audio and video.

I also tried installing an older Version of Jitsi, but withoput success. Maybe the problem lies deeper within the system and I need to make some changes somewhere…

By the way, I want to thank you for your help and quick responses, I really hope we can get this to run on that server… If i would understand this software a bit better, how its components work together, I think I would have less trouble… But I learned a lot in the process and am very glad I took this journey!