No audio between jigasi and freepbx in conference

I don’t exactily where the problem is. I read (Tutorial - Jitsi / Jigasi & FreePBX integration. Along with Asterisk IVR to use Jitsi conference mapper API) for freepbx and jigasi here in the forum, and tried to implement it on our side:

So the caller can now join per phone a meeting but don’t hear anything and also no one in the meeting hears him. The only thing that i see in the log, is the following

2021-06-08 17:31:41.397 INFO: [102] org.jitsi.jigasi.SipGatewaySession.peerStateChanged().1680 [ctx=16231662988231828803221] SIP peer state: Connecting*
2021-06-08 17:31:41.432 INFO: [127] org.jitsi.jigasi.SipGatewaySession.handleCallState().1597 [ctx=16231662988231828803221] Sip call IN_PROGRESS: Call: id=16231662987721413291048 peers=1
2021-06-08 17:31:41.432 INFO: [127] org.jitsi.jigasi.SipGatewaySession.handleCallState().1606 [ctx=16231662988231828803221] SIP call format used: rtpmap:8 PCMA/8000
2021-06-08 17:31:41.447 INFO: [127] org.jitsi.jigasi.SipGatewaySession.peerStateChanged().1680 [ctx=16231662988231828803221] SIP peer state: Connected
2021-06-08 17:31:41.460 INFO: [127] service.protocol.media.CallPeerMediaHandler.start().1961 Starting
2021-06-08 17:31:41.513 SEVERE: [140] net.sf.fmj.media.Log.error() Failed to build a graph for the given custom options.
2021-06-08 17:31:41.514 SEVERE: [140] net.sf.fmj.media.Log.error() Failed to realize: net.sf.fmj.media.ProcessEngine@24b62d66
2021-06-08 17:31:41.515 SEVERE: [140] net.sf.fmj.media.Log.error()   Cannot build a flow graph with the customized options:
2021-06-08 17:31:41.515 SEVERE: [140] net.sf.fmj.media.Log.error()     Unable to transcode format: LINEAR, 48000.0 Hz, 16-bit, Mono, LittleEndian, Signed
2021-06-08 17:31:41.515 SEVERE: [140] net.sf.fmj.media.Log.error()       to: opus/rtp, 48000.0 Hz, Stereo
2021-06-08 17:31:41.515 SEVERE: [140] net.sf.fmj.media.Log.error()       outputting to: raw.rtp
2021-06-08 17:31:41.516 SEVERE: [140] net.sf.fmj.media.Log.error()     Unable to add customed codecs:
2021-06-08 17:31:41.516 SEVERE: [140] net.sf.fmj.media.Log.error()       org.jitsi.impl.neomedia.audiolevel.AudioLevelEffect2@1201c7f3
2021-06-08 17:31:41.516 SEVERE: [137] net.sf.fmj.media.Log.error() Error: Unable to realize net.sf.fmj.media.ProcessEngine@24b62d66
2021-06-08 17:31:41.544 INFO: [103] org.jitsi.jigasi.JvbConference.callStateChanged().1485 [ctx=16231662988231828803221] JVB conference call IN_PROGRESS.
2021-06-08 17:31:41.560 INFO: [113] org.jitsi.srtp.crypto.OpenSslWrapperLoader.log() jitsisrtp successfully loaded
2021-06-08 17:31:41.603 INFO: [127] service.protocol.media.TransportManager.sendHolePunchPacket().552 Send NAT hole punch packets
2021-06-08 17:31:41.646 SEVERE: [190] net.sf.fmj.media.Log.error()   Unable to handle format: LINEAR, 48000.0 Hz, 16-bit, Mono, LittleEndian, Signed
2021-06-08 17:31:41.647 SEVERE: [190] net.sf.fmj.media.Log.error() Failed to prefetch: net.sf.fmj.media.ProcessEngine@42d15480
2021-06-08 17:31:41.647 SEVERE: [186] net.sf.fmj.media.Log.error() Error: Unable to prefetch net.sf.fmj.media.ProcessEngine@42d15480
2021-06-08 17:34:17.219 INFO: [238] org.jitsi.jigasi.SipGatewaySession.handleCallState().1614 [ctx=16231662988231828803221] SIP call ended: CallPeerChangeEvent: type=CallPeerStatusChange oldV=net.java.sip.communicator.service.protocol.CallPeerState:Connected newV=net.java.sip.communicator.service.protocol.CallPeerState:Disconnected for peer=xxx<xxx@x.x.x.x>;status=Disconnected

So the only error message i receive ist the message above , and i don’t know what is wrong.

1 Like

I have the same problem with using jigasi and my Xivo IPBX service (based on Asterisk). I can call any conference from a phone number and join my conference with the PIN code but no audio is transmitted. I have the exact same error in the log.

2021-06-15 08:53:10.745 GRAVE: [545] net.sf.fmj.media.Log.error() Unable to handle format: LINEAR, 48000.0 Hz, 16-bit, Mono, LittleEndian, Signed
2021-06-15 08:53:10.745 GRAVE: [545] net.sf.fmj.media.Log.error() Failed to prefetch: net.sf.fmj.media.ProcessEngine@b1aa062
2021-06-15 08:53:10.748 GRAVE: [543] net.sf.fmj.media.Log.error() Error: Unable to prefetch net.sf.fmj.media.ProcessEngine@b1aa062

Can anyone help us

Is your setting of the server to do latching for that account?
In asterisk it used to be nat=yes some years ago.