No Audio Between FreePBX and Jigasi Dial-In

I have set up FreePBX and Jigasi Dial-in. The conference can connect successfully but there’s no audio for any participants. Here are the steps I have tried:

  1. No problems for softphone. I can register softphone to FreePBX and call the extension 101 registered from Jigasi. The audio is working fine.
  2. When using Dial-in calling through DID from FreePBX to join the Jitsi conference, there’s no audio.
  3. Tried to set the codec for Jigasi extension on FreePBX to g711 ulaw only and still not working.

Here’s part of the Jigasi config:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP:101@x.x.x.x
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=x.x.x.x
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=101@x.x.x.x
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25
#net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=NONE
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.VOICEMAIL_ENABLED=false
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.AMR-WB/16000=750
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.G722/8000=700
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.GSM/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.H263-1998/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.H264/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.PCMA/8000=600
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.PCMU/8000=650
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/12000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/24000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.VP8/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.iLBC/8000=10
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.opus/48000=1000
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.red/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/32000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.telephone-event/8000=1
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.ulpfec/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DEFAULT_ENCRYPTION=false

Any idea on how to resolve this?

Thanks,
Henry

Is this Jitsi Desktop soft phone? If yes you can use the advanced properties editor and use same settings for jigasi.

You need to make sure your sip account is configured to do latching.

  1. Jitsi desktop and APP from Apple store are working to Jitsi video conference.
  2. Use other softphone like linphone to register to FreePBX extension 102 or 103, and call to Jigasi extension 101. The audio is working.
  3. Use phone cellular to dial in from DID to FreePBX to join the conference with Jigasi extension 101. The audio is not working.

What do you mean by latching? How to configure it?

Thank you,
Henry

Also tried below and none is working.

  1. Configured Jigasi extension 101 in 2 ways on FreePBX:
    a. RTP Symmetric = yes, Force rport = yes
    b. RTP Symmetric = no, Force rport = no

  2. Turned off firewalls on both FreePBX and Jitsi servers.

Asterisk setting is
nat=force_rport,comedia

I’m using PJSIP. And tried below config in pjsip.endpoint.conf and not working.

media_use_received_transport=yes
rtp_symmetric=yes
force_rport=yes

Still no luck. Any more ideas?

Wireshark on jigasi side, to check whether you send and receive media from the sip side.

Tried that. I can see the rtp udp packets from and to the ports with correct payload type.

in jigasi.log file, I see these logs:

2022-02-04 17:15:24.183 INFO: [88] service.protocol.media.MediaHandler.registerDynamicPTsWithStream().1003 Dynamic PT map: 126=rtpmap:-1 telephone-event/8000; 111=rtpmap:-1 opus/48000/2 fmtp:useinbandfec=1;minptime=10; 103=rtpmap:-1 unknown/90000;
2022-02-04 17:15:24.184 INFO: [88] service.protocol.media.MediaHandler.registerDynamicPTsWithStream().1020 PT overrides [103->104 ]
2022-02-04 17:15:24.186 INFO: [88] service.protocol.media.CallPeerMediaHandler.start().1961 Starting
2022-02-04 17:15:24.257 SEVERE: [2928] net.sf.fmj.media.Log.error() Failed to build a graph for the given custom options.
2022-02-04 17:15:24.263 SEVERE: [2928] net.sf.fmj.media.Log.error() Failed to realize: net.sf.fmj.media.ProcessEngine@1fd94b2c
2022-02-04 17:15:24.263 SEVERE: [2928] net.sf.fmj.media.Log.error() Cannot build a flow graph with the customized options:
2022-02-04 17:15:24.264 SEVERE: [2928] net.sf.fmj.media.Log.error() Unable to transcode format: LINEAR, 48000.0 Hz, 16-bit, Mono, LittleEndian, Signed
2022-02-04 17:15:24.264 SEVERE: [2928] net.sf.fmj.media.Log.error() to: opus/rtp, 48000.0 Hz, Stereo
2022-02-04 17:15:24.264 SEVERE: [2928] net.sf.fmj.media.Log.error() outputting to: raw.rtp
2022-02-04 17:15:24.264 SEVERE: [2928] net.sf.fmj.media.Log.error() Unable to add customed codecs:
2022-02-04 17:15:24.265 SEVERE: [2928] net.sf.fmj.media.Log.error() org.jitsi.impl.neomedia.audiolevel.AudioLevelEffect2@c781f6e
2022-02-04 17:15:24.267 SEVERE: [2927] net.sf.fmj.media.Log.error() Error: Unable to realize net.sf.fmj.media.ProcessEngine@1fd94b2c
2022-02-04 17:15:24.273 INFO: [88] org.jitsi.jigasi.JvbConference.callStateChanged().1466 [ctx=16439949229712017980280] JVB conference call IN_PROGRESS.

Does jigasi use opus codec? Seems it can’t transcode it. Do I miss some modules for jigasi?
I tried commented out all other codecs in file sip-communicator.properties and only left PCMU yesterday, it wasn’t work.

Hum, you should see at least the hole punch packets. Yeah opus is configured … But pcma and pcmu doesn’t use any natives, you should be seeing those packets. Can you send me a pcap with udp pcakets in private message using pcma or pcmu?

How can I send you in private message?

I got the trace ready. How can I send to you?

send it to damencho at jitsi dot org

Send to you. The subject is Trace for “No Audio Between FreePBX and Jigasi Dial-In”.

In your dump you can see the sip session is established correctly and there is a two-way audio between jigasi and FreePBX.

Have you tried 3way call on your deployment, no jigasi just 3 tabs from chrome, do you hear the audio?