No audio and video in recordings

Hello, I’m having some problems with recordings in jitsi: the recording seems to work fine, but no video or audio is actually recorded. I’ve explored the forum and Ive’ found a similar thread but the solution does not apply here: the trusted-domains seems correct in my case. I’ve noticed though that the participats field is always empty in the metadata.json file.

You can find the logs of the installation here: https://livestream2.iskilled.it/iskilled/logsjitsi.tgz

What could be the reason of this problem?

Thank in advance,
Francesco

Maybe jibri cannot communicate with JVB

Thank you so much for trying to help me. This is what I see when I replay the video:

In fact I was not very clear… the video is present but with a fake image, like if I had not attached the camera to my pc (but I had done it and I was seeing the video while recording).

Could it be a chromedriver problem?

Thank you in advance,
Francesco

I’ve found an interesting message in /var/log/jitsi/jibri/browser.0.txt:

2021-12-01 11:03:47.075 INFO: [43] browser.log() [2021-12-01T11:03:17+0000] [WARNING] https://livestream2.iskilled.it/libs/lib-jitsi-meet.min.js?v=5415 9:20962 “2021-12-01T11:03:17.597Z” “[modules/RTC/RTCUtils.js]” “Failed to get access to local media. NotReadableError: Could not start audio source {“video”:false,“audio”:{“autoGainControl”:true,“echoCancellation”:true,“noiseSuppression”:true}}”

I’ve solved: I’m reporting it here so that it can be useful to others.

setting strip-from-room-domain = “conference.” in jibri.conf solved the problem (before the line was strip-from-room-domain = “”).

Have a nice day,
Francesco