No audio and video in meetings

Hi!

Since wednesday my self-hosted Jitsi have problems: the users of the room can’t see and can’t speak (no audio).

I saw the var/log/jitsi/jicofon.log but I don’t see any error.

Any else?

Did you change anything? The first place to check would be the JS console logs when a participant joins.

Well, I tried in Firefox and it works, but in Chrome not (it’s the version 86) :confused:

But it’s curious, because I tried in another self-hosted server (test) and it works in Chrome :confused: :confused:

  • Production server: Chrome 86 (doesn’t work), Firefox (Works)
  • Test server: Works with Chrome and Firefox

And in production server I didn’t change anything :frowning:

I think I may know the problem. Do you have the insertable streams origin trial enabled by chance? JS console logs would help here.

Well, in the console I look this errors:

2020-10-16T10:15:26.767Z [features/base/tracks] <x/</<>:  Failed to create local tracks 
Array [ "audio", "video" ]
 
Object { gum: {…}, name: "gum.general", message: "Failed to allocate videosource", stack: "s@https://mydomain.com/libs/lib-jitsi-meet.min.js?v=4127:1:113315\n_newGetUserMediaWithConstraints/</<@https://mydomain.com/libs/lib-jitsi-meet.min.js?v=4127:1:91969\n" }

And this:

2020-10-16T10:21:19.567Z [JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>:  UnhandledError: null Script: null Line: null Column: null StackTrace:  DOMException: Failed to execute 'createEncodedStreams' on 'RTCRtpSender': Encoded video streams not requested at PC initialization
    at a.handleSender (
https://mydomain.com/libs/lib-jitsi-meet.min.js?v=4127:17:26576
)
    at se._setupSenderE2EEForTrack (
https://mydomain.com/libs/lib-jitsi-meet.min.js?v=4127:10:195859
)
    at se._setupNewTrack (

Yeah, it’s what I suspected. Can you update to the latest stable version? This is fixed there already.

Yeah! I found this and it works!!

https://community.jitsi.org/t/help-stops-work-with-new-chrome-version-86-0-4240-75/80715/31

Also, next week I will update Jitsi in test server to do test.

Thanks saghul!