No audio and video behind NAT

meet

#1

I have latest Jitsi meet installed on Ubuntu 18.04 server, from LAN it is workong perfect, but from outside there is no audio/video. Proper ports are forwsrded on my router, public IP provided in config. Where is the problem?


#2

Hello,

I was told this


#3

Yes, private and public ip configured in jvb config, i can connect, create room, but no videovaudio or chst, amd disconnect in few seconds.


#4

On LAN video and sudio works for 20+ users


#5

Did you try to see if there was a javascript error when the user is outside the firewall ?


#6

Normally symptomps like yours the problem are ports and/or addresses https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md#advanced-configuration
You can send a link to try it.


#7

443, 4443, 10000-20000 are forwarded correctly, addresses in videobridge config are set. I tried even to set th jitsi server as a DMZ host on router - no changes. When i enter the room in Jitsi meet it asks me for permission to use my camera and microphone, i click Allow, then i see a blank black video window (camera LED on my laptop is on), and muted microphone icon (cannot unmute). Chart asks for a nickname, when I enter it - it doesn’t apply, chat is not working too. The only buttons working - is Raise/Lower hand, settings, and leave room. When I connect from LAN, even through our proxy (squid, FreeBsd) - everything is OK. Up to 20+ users. From outside - nothing. No matter Chrome, Firefox, or other browser.
https://193.238.97.170/VODA


#8

Your configuration is wrong, you are accessing the deployment from https://193.238.97.170 but your bosh connection has internal IP which cannot be accessed from the internet

bosh: '//192.168.0.135/http-bind',

#9

Where can I configure it? Jvb config?
My sip-communicator.properties:


#10

The config is in /etc/jitsi/meet/192…-config.js
Try changing there the bosh connection and test, but I suspect you will hit another problems … cause of this mismatch.

Normally when you install you enter the name you will use for the deployment, like DNS name like ‘meet.jit.si’. With correct DNS you can also install valid lets encrypt certificates, where with using an ip address you cannot use those.


#11

I will try to change config.
Is it possible to set domain name without reinstalling?


#12

Generally you have to change each occurrence of the IP address in the config files with the domain name and then issue a new SSL certificate for the domain. As you are using Jetty and not a separate webserver, you have to also add the certificate to the java keystore. Ten you restart all the services.

If you can just afford a reinstallation, it could be easier/faster.


#13

Changed config. Now my video and audio works from outside. Another problem - now only one participant can have video, and users can’t see or hear each other, when, for example, second user, connects to room, he have his own video, my video is black and disappears in a few seconds. Chat is not working too, but a bit different - I can set my nickname, write some text, but when I hit Enter, text just disappears.
UPD: Now it’s not working correctly on local network - no audio/video.


#14

Looks like your videobridge is not working. Look at /var/log/jitsi/jvb.log for errors. Look at the prosody log (as chat is not working, there could be a problem too) in /var/log/prosody/


#15

New problem - I reinstalled ubuntu and jitsi-meet, even used domain name this time, not IP address - nothing changed - video and audio works from outside, but only for one user, when second enters room - both disconnected. (after adding local and public addresses - only second user disconnects after a few seconds). On LAN (when i tried to use https://local IP/room) - no video, no audio, no chat.
When I connect from outside - chat works until somebody tries to connect - when the other user is kicked, i can enter text, but it is not shown in chat window.
I have strings with local and public IP in sip.communicator.properties, do i need them, when i use domain name? Or the public address must be a domain name?


#16

You have to access the service by the string you entered in the install - domain name or ip address. You can’t access it both ways. When testing from inside the LAN, associate the domain name with the local IP in the hosts file, so that you access it by name from LAN too.

If you don’t see the other participants (what was the error, does it try to reconnect or what) this means that most probably you have an issue with the jitsi-videobridge. Look at /var/log/jitsi/jvb.log for the errors.