No admin in room

when i join a room as a first user I am not the admin even the other users are not admin i.e. room without admin so I can’t record do you have an idea please
this my jicofo config

jicofo.config

jicofo {
xmpp: {
client: {
client-proxy: focus.meet.test.dev
}
trusted-domains: [ “recorder.meet.test.dev” ]
}
bridge: {
brewery-jid: “JvbBrewery@internal.auth.meet.test.dev”
}
}

jicofo/config

Jitsi Conference Focus settings

sets the host name of the XMPP server

JICOFO_HOST=localhost

sets the XMPP domain (default: none)

JICOFO_HOSTNAME=meet.test.dev

sets the XMPP domain name to use for XMPP user logins

JICOFO_AUTH_DOMAIN=auth.meet.test.dev

sets the username to use for XMPP user logins

JICOFO_AUTH_USER=focus

sets the password to use for XMPP user logins

JICOFO_AUTH_PASSWORD=xxxxx

extra options to pass to the jicofo daemon

JICOFO_OPTS=""

adds java system props that are passed to jicofo (default are for home and logging config file)

JAVA_SYS_PROPS="-Dconfig.file=/etc/jitsi/jicofo/jicofo.conf -Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=jicofo -Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi -Djava.util.logging.config.file=/etc/jitsi/jicofo/logging.properties"

sip -communicator:

org.jitsi.jicofo.BRIDGE_MUC=JvbBrewery@internal.meet.test.dev
org.jitsi.jicofo.jibri.BREWERY=JibriBrewery@internal.auth.meet.test.dev
org.jitsi.jicofo.XMPP_MUC_COMPONENT_PREFIX=muc
org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90

Everything looks good. Open the js console and filter woth word role, what do you see?

Not connected to the problem, but this seems wrong

In the other thread you pasted prosody config and your main muc component prefix is conference. Not sure where is this used, though