NGINX server_names_hash_bucket_size parameter make troubles with CertBot

Hi all

The server_names_hash_bucket_size parameter in NGINX config file makes a lot of troubels.

It’s better to move it in /etc/nginx/nginx.conf to avoid parsing error with certbot if you have more than one domain.

@damencho could you fix this?

1 Like

I also got an error when I tried to renew all of my server’s certificates today, making the process impossible to finish:

Cert is due for renewal, auto-renewing...
Plugins selected: Authenticator nginx, Installer nginx
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for ****.com
nginx: [emerg] "server_names_hash_bucket_size" directive is duplicate in /etc/nginx/sites-enabled/meet.******.com.conf:1
Cleaning up challenges
Attempting to renew cert (****.com) from /etc/letsencrypt/renewal/****.com.conf produced an unexpected error: nginx restart failed:

. Skipping.

Commenting the line server_names_hash_bucket_size 64; in /etc/nginx/sites-enabled/meet.******.conf fixed it for me but might not be ideal because it’s probably needed at some point by Jitsi…

1 Like

that’s why i said to jitsi to fix this.

@damencho any feedback on update status fo this big trouble?

1 Like

Right. It should be moved to nginx.conf.

@damencho does you have an ETA for a fix?