Nginx Proxy Pass for muc_size working in Browser, but not Postman


I’m trying to open up an endpoint on my nginx for the mod_muc_size plugin. I have the problem, that getting the url in the browser works and returns everything properly, but in Postman I get

Could not get any response

or when trying to use fetch I’m getting:

UnhandledPromiseRejectionWarning: TypeError: Only absolute URLs are supported

I copied the config from various posts on here, but disabled the Host header, because then the browser doesn’t even the response, it get’s 404 with the Host header enabled.

My nginx config for that part:

    location = /status {
        proxy_pass      http://localhost:5280/status?domain=$http_host&$args;
        proxy_set_header X-Forwarded-For $remote_addr;
        # if I enable the following, I get 404 in the browser
        # proxy_set_header Host $host;

Any ideas on what the proper config is?

After working hours on this issue, I found the issue in the 60-jitsi-meet.conf nginx config.

Postman/Fetch requests get aught by the default in the $ssl_preread_alpn_protocols map, thus getting send to the turn server. Not sure yet how to fix this.

– Update:

For now I switched out the web/turn map:

    map $ssl_preread_alpn_protocols $upstream {
        ~\bstun\.turn\b  turn;
        default          web;