Nginx proxy manager: doesn't work with Jitsi

I currently host Jitsi Meet (Docker), and am trying to learn how to setup a reverse proxy so that I can use other services from the same VPS. After some reading, much confusion, and endless back-and-forth, I decided to use jc21’s nginx proxy manager. Turns out it wasn’t as easy as I thought, and I need help figuring out how to get it to work with Jitsi.

I made it through setup, and think I was able to get reverse proxy for the nginx web interface working. Here’s how I did it:

  1. Add Proxy Host
  • Domain name: nginx.mydomain.tld
  • Scheme: http
  • Hostname/IP: [internal LAN IP of the nginx Docker container]
  • Forward port: 81
  1. Enter “https://nginx.mydomain.tld” in my browser >> correctly redirects to nginx web interface

When I try to replicate with the corresponding Jitsi settings, I get a “502 Bad Gateway (nginx)” error when I go to “https://jitsi.mydomain.tld”. I am using the Hostname/IP of the jitsi/web Docker container. My Jitsi ports have been left as default in .env (HTTP = 8000 / HTTP = 8443).

What’s strange is that if I type “https://mypublicip:8443” into my browser, it correctly redirects to Jitsi! Same thing if I type “https://mydomain.tld:8443”, and also if I do the same thing using the nginx port (81).

Questions

1 Like