Nginx port 4444

how can i change ssl port 4444 to port 443?
if I change it to /etc/nginx/site-enable/meet.xxxx.com
nginx is not working
systemd[1]: Failed to start A high perform>
░░ Subject: A start job for unit nginx.service has failed

Is there any other process which is listening TCP/443?

sudo ss -tulpn
Netid State Recv-Q Send-Q Local Address:Port Peer Address:Port Process
udp UNCONN 0 0 192.168.2.56:53 0.0.0.0:* users:((“named”,pid=549,fd=68))
udp UNCONN 0 0 192.168.2.56:53 0.0.0.0:* users:((“named”,pid=549,fd=69))
udp UNCONN 0 0 192.168.2.56:53 0.0.0.0:* users:((“named”,pid=549,fd=67))
udp UNCONN 0 0 192.168.2.56:53 0.0.0.0:* users:((“named”,pid=549,fd=66))
udp UNCONN 0 0 127.0.0.1:53 0.0.0.0:* users:((“named”,pid=549,fd=38))
udp UNCONN 0 0 127.0.0.1:53 0.0.0.0:* users:((“named”,pid=549,fd=39))
udp UNCONN 0 0 127.0.0.1:53 0.0.0.0:* users:((“named”,pid=549,fd=40))
udp UNCONN 0 0 127.0.0.1:53 0.0.0.0:* users:((“named”,pid=549,fd=37))
udp UNCONN 0 0 0.0.0.0:68 0.0.0.0:* users:((“dhclient”,pid=494,fd=9))
udp UNCONN 0 0 0.0.0.0:5000 0.0.0.0:* users:((“java”,pid=544,fd=163))
udp UNCONN 0 0 192.168.2.56:5349 0.0.0.0:* users:((“turnserver”,pid=532,fd=28))
udp UNCONN 0 0 192.168.2.56:5349 0.0.0.0:* users:((“turnserver”,pid=532,fd=27))
udp UNCONN 0 0 192.168.2.56:5349 0.0.0.0:* users:((“turnserver”,pid=532,fd=26))
udp UNCONN 0 0 192.168.2.56:5349 0.0.0.0:* users:((“turnserver”,pid=532,fd=25))
udp UNCONN 0 0 :43535 : users:((“python”,pid=2002,fd=4))
udp UNCONN 0 0 [::1]:53 [::]:
users:((“named”,pid=549,fd=49))
udp UNCONN 0 0 [::1]:53 [::]:* users:((“named”,pid=549,fd=50))
udp UNCONN 0 0 [::1]:53 [::]:* users:((“named”,pid=549,fd=52))
udp UNCONN 0 0 [::1]:53 [::]:* users:((“named”,pid=549,fd=51))
udp UNCONN 0 0 [fe80::6d4:c4ff:fe8d:63ae]%enp8s0:53 [::]:* users:((“named”,pid=549,fd=57))
udp UNCONN 0 0 [fe80::6d4:c4ff:fe8d:63ae]%enp8s0:53 [::]:* users:((“named”,pid=549,fd=58))
udp UNCONN 0 0 [fe80::6d4:c4ff:fe8d:63ae]%enp8s0:53 [::]:* users:((“named”,pid=549,fd=60))
udp UNCONN 0 0 [fe80::6d4:c4ff:fe8d:63ae]%enp8s0:53 [::]:* users:((“named”,pid=549,fd=59))
udp UNCONN 0 0 [2a02:a444:20c8:1:6d4:c4ff:fe8d:63ae]:53 [::]:* users:((“named”,pid=549,fd=75))
udp UNCONN 0 0 [2a02:a444:20c8:1:6d4:c4ff:fe8d:63ae]:53 [::]:* users:((“named”,pid=549,fd=76))
udp UNCONN 0 0 [2a02:a444:20c8:1:6d4:c4ff:fe8d:63ae]:53 [::]:* users:((“named”,pid=549,fd=77))
udp UNCONN 0 0 [2a02:a444:20c8:1:6d4:c4ff:fe8d:63ae]:53 [::]:* users:((“named”,pid=549,fd=78))
udp UNCONN 0 0 :53506 : users:((“uwsgi”,pid=1709,fd=9),(“uwsgi”,pid=1708,fd=9),(“uwsgi”,pid=994,fd=9))
udp UNCONN 0 0 [::]:5000 [::]:
users:((“java”,pid=544,fd=164))
udp UNCONN 0 0 :41998 : users:((“java”,pid=540,fd=8))
udp UNCONN 0 0 [::ffff:192.168.2.56]:10000 : users:((“java”,pid=544,fd=160))
udp UNCONN 0 0 [2a02:a444:20c8:1:6d4:c4ff:fe8d:63ae]:10000 [::]:
users:((“java”,pid=544,fd=159))
tcp LISTEN 0 1024 192.168.2.56:5349 0.0.0.0:* users:((“turnserver”,pid=532,fd=48))
tcp LISTEN 0 1024 192.168.2.56:5349 0.0.0.0:* users:((“turnserver”,pid=532,fd=46))
tcp LISTEN 0 1024 192.168.2.56:5349 0.0.0.0:* users:((“turnserver”,pid=532,fd=44))
tcp LISTEN 0 1024 192.168.2.56:5349 0.0.0.0:* users:((“turnserver”,pid=532,fd=42))
tcp LISTEN 0 511 0.0.0.0:5222 0.0.0.0:* users:((“lua5.2”,pid=1797,fd=10))
tcp LISTEN 0 4096 127.0.0.1:10024 0.0.0.0:* users:((“/usr/sbin/amavi”,pid=2288,fd=7),(“/usr/sbin/amavi”,pid=2287,fd=7),(“/usr/sbin/amavi”,pid=598,fd=7))
tcp LISTEN 0 100 127.0.0.1:10025 0.0.0.0:* users:((“master”,pid=1991,fd=123))
tcp LISTEN 0 4096 127.0.0.1:10026 0.0.0.0:* users:((“/usr/sbin/amavi”,pid=2288,fd=9),(“/usr/sbin/amavi”,pid=2287,fd=9),(“/usr/sbin/amavi”,pid=598,fd=9))
tcp LISTEN 0 80 127.0.0.1:3306 0.0.0.0:* users:((“mariadbd”,pid=826,fd=23))
tcp LISTEN 0 100 0.0.0.0:587 0.0.0.0:* users:((“master”,pid=1991,fd=27))
tcp LISTEN 0 511 127.0.0.1:6379 0.0.0.0:* users:((“redis-server”,pid=554,fd=6))
tcp LISTEN 0 1024 127.0.0.1:11211 0.0.0.0:* users:((“memcached”,pid=547,fd=26))
tcp LISTEN 0 4096 127.0.0.1:9998 0.0.0.0:* users:((“/usr/sbin/amavi”,pid=2288,fd=5),(“/usr/sbin/amavi”,pid=2287,fd=5),(“/usr/sbin/amavi”,pid=598,fd=5))
tcp LISTEN 0 100 127.0.0.1:9999 0.0.0.0:* users:((“python”,pid=2002,fd=8))
tcp LISTEN 0 100 0.0.0.0:143 0.0.0.0:* users:((“dovecot”,pid=535,fd=38))
tcp LISTEN 0 511 0.0.0.0:80 0.0.0.0:* users:((“nginx”,pid=139556,fd=12),(“nginx”,pid=139555,fd=12),(“nginx”,pid=139554,fd=12),(“nginx”,pid=139553,fd=12),(“nginx”,pid=139552,fd=12))
tcp LISTEN 0 5 127.0.0.1:5232 0.0.0.0:* users:((“radicale”,pid=2005,fd=5))
tcp LISTEN 0 511 0.0.0.0:5269 0.0.0.0:* users:((“lua5.2”,pid=1797,fd=7))
tcp LISTEN 0 10 192.168.2.56:53 0.0.0.0:* users:((“named”,pid=549,fd=72))
tcp LISTEN 0 10 192.168.2.56:53 0.0.0.0:* users:((“named”,pid=549,fd=73))
tcp LISTEN 0 10 192.168.2.56:53 0.0.0.0:* users:((“named”,pid=549,fd=71))
tcp LISTEN 0 10 192.168.2.56:53 0.0.0.0:* users:((“named”,pid=549,fd=70))
tcp LISTEN 0 10 127.0.0.1:53 0.0.0.0:* users:((“named”,pid=549,fd=46))
tcp LISTEN 0 10 127.0.0.1:53 0.0.0.0:* users:((“named”,pid=549,fd=44))
tcp LISTEN 0 10 127.0.0.1:53 0.0.0.0:* users:((“named”,pid=549,fd=42))
tcp LISTEN 0 10 127.0.0.1:53 0.0.0.0:* users:((“named”,pid=549,fd=41))
tcp LISTEN 0 128 0.0.0.0:22 0.0.0.0:* users:((“sshd”,pid=744,fd=3))
tcp LISTEN 0 244 127.0.0.1:5432 0.0.0.0:* users:((“postgres”,pid=851,fd=6))
tcp LISTEN 0 4096 127.0.0.1:12345 0.0.0.0:* users:((“opendkim”,pid=2024,fd=5))
tcp LISTEN 0 100 0.0.0.0:25 0.0.0.0:* users:((“master”,pid=1991,fd=13))
tcp LISTEN 0 4096 127.0.0.1:953 0.0.0.0:* users:((“named”,pid=549,fd=36))
tcp LISTEN 0 511 0.0.0.0:443 0.0.0.0:* users:((“nginx”,pid=139556,fd=10),(“nginx”,pid=139555,fd=10),(“nginx”,pid=139554,fd=10),(“nginx”,pid=139553,fd=10),(“nginx”,pid=139552,fd=10))
tcp LISTEN 0 511 0.0.0.0:4444 0.0.0.0:* users:((“nginx”,pid=139556,fd=14),(“nginx”,pid=139555,fd=14),(“nginx”,pid=139554,fd=14),(“nginx”,pid=139553,fd=14),(“nginx”,pid=139552,fd=14))
tcp LISTEN 0 100 0.0.0.0:4190 0.0.0.0:* users:((“dovecot”,pid=535,fd=15))
tcp LISTEN 0 511 0.0.0.0:5280 0.0.0.0:* users:((“lua5.2”,pid=1797,fd=12))
tcp LISTEN 0 100 0.0.0.0:993 0.0.0.0:* users:((“dovecot”,pid=535,fd=40))
tcp LISTEN 0 511 :9091 : users:((“node”,pid=2279,fd=21))
tcp LISTEN 0 50 :3333 : users:((“java”,pid=540,fd=26))
tcp LISTEN 0 511 [::]:5222 [::]:
users:((“lua5.2”,pid=1797,fd=11))
tcp LISTEN 0 4096 [::1]:10024 [::]:
users:((“/usr/sbin/amavi”,pid=2288,fd=8),(“/usr/sbin/amavi”,pid=2287,fd=8),(“/usr/sbin/amavi”,pid=598,fd=8))
tcp LISTEN 0 4096 [::1]:10026 [::]:* users:((“/usr/sbin/amavi”,pid=2288,fd=11),(“/usr/sbin/amavi”,pid=2287,fd=11),(“/usr/sbin/amavi”,pid=598,fd=11))
tcp LISTEN 0 100 [::]:587 [::]:* users:((“master”,pid=1991,fd=28))
tcp LISTEN 0 511 [::1]:6379 [::]:* users:((“redis-server”,pid=554,fd=7))
tcp LISTEN 0 4096 [::1]:9998 [::]:* users:((“/usr/sbin/amavi”,pid=2288,fd=6),(“/usr/sbin/amavi”,pid=2287,fd=6),(“/usr/sbin/amavi”,pid=598,fd=6))
tcp LISTEN 0 50 :2222 : users:((“java”,pid=540,fd=38))
tcp LISTEN 0 100 [::1]:9999 [::]:
users:((“python”,pid=2002,fd=9))
tcp LISTEN 0 100 [::]:143 [::]:* users:((“dovecot”,pid=535,fd=39))
tcp LISTEN 0 511 [::]:80 [::]:* users:((“nginx”,pid=139556,fd=13),(“nginx”,pid=139555,fd=13),(“nginx”,pid=139554,fd=13),(“nginx”,pid=139553,fd=13),(“nginx”,pid=139552,fd=13))
tcp LISTEN 0 50 [::ffff:127.0.0.1]:8080 : users:((“java”,pid=544,fd=151))
tcp LISTEN 0 5 [::1]:5232 [::]:* users:((“radicale”,pid=2005,fd=6))
tcp LISTEN 0 511 [::]:5269 [::]:* users:((“lua5.2”,pid=1797,fd=8))
tcp LISTEN 0 32 :21 : users:((“vsftpd”,pid=576,fd=3))
tcp LISTEN 0 10 [::1]:53 [::]:
users:((“named”,pid=549,fd=53))
tcp LISTEN 0 10 [::1]:53 [::]:* users:((“named”,pid=549,fd=54))
tcp LISTEN 0 10 [::1]:53 [::]:* users:((“named”,pid=549,fd=55))
tcp LISTEN 0 10 [::1]:53 [::]:* users:((“named”,pid=549,fd=56))
tcp LISTEN 0 10 [fe80::6d4:c4ff:fe8d:63ae]%enp8s0:53 [::]:* users:((“named”,pid=549,fd=61))
tcp LISTEN 0 10 [fe80::6d4:c4ff:fe8d:63ae]%enp8s0:53 [::]:* users:((“named”,pid=549,fd=62))
tcp LISTEN 0 10 [fe80::6d4:c4ff:fe8d:63ae]%enp8s0:53 [::]:* users:((“named”,pid=549,fd=63))
tcp LISTEN 0 10 [fe80::6d4:c4ff:fe8d:63ae]%enp8s0:53 [::]:* users:((“named”,pid=549,fd=64))
tcp LISTEN 0 10 [2a02:a444:20c8:1:6d4:c4ff:fe8d:63ae]:53 [::]:* users:((“named”,pid=549,fd=79))
tcp LISTEN 0 10 [2a02:a444:20c8:1:6d4:c4ff:fe8d:63ae]:53 [::]:* users:((“named”,pid=549,fd=80))
tcp LISTEN 0 10 [2a02:a444:20c8:1:6d4:c4ff:fe8d:63ae]:53 [::]:* users:((“named”,pid=549,fd=81))
tcp LISTEN 0 10 [2a02:a444:20c8:1:6d4:c4ff:fe8d:63ae]:53 [::]:* users:((“named”,pid=549,fd=82))
tcp LISTEN 0 128 [::]:22 [::]:* users:((“sshd”,pid=744,fd=4))
tcp LISTEN 0 50 :8888 : users:((“java”,pid=606,fd=100))
tcp LISTEN 0 244 [::1]:5432 [::]:
users:((“postgres”,pid=851,fd=5))
tcp LISTEN 0 100 [::]:25 [::]:* users:((“master”,pid=1991,fd=14))
tcp LISTEN 0 4096 [::1]:953 [::]:* users:((“named”,pid=549,fd=65))
tcp LISTEN 0 511 :3002 : users:((“node”,pid=2279,fd=18))
tcp LISTEN 0 511 [::]:443 [::]:
users:((“nginx”,pid=139556,fd=11),(“nginx”,pid=139555,fd=11),(“nginx”,pid=139554,fd=11),(“nginx”,pid=139553,fd=11),(“nginx”,pid=139552,fd=11))
tcp LISTEN 0 511 [::]:4444 [::]:* users:((“nginx”,pid=139556,fd=15),(“nginx”,pid=139555,fd=15),(“nginx”,pid=139554,fd=15),(“nginx”,pid=139553,fd=15),(“nginx”,pid=139552,fd=15))
tcp LISTEN 0 100 [::]:4190 [::]:* users:((“dovecot”,pid=535,fd=16))
tcp LISTEN 0 511 [::]:5280 [::]:* users:((“lua5.2”,pid=1797,fd=13))
tcp LISTEN 0 100 [::]:993 [::]:* users:((“dovecot”,pid=535,fd=41))
tcp LISTEN 0 50 *:9090 : users:((“java”,pid=544,fd=142))

I don’t see port 443 being used

tcp LISTEN 0 511 0.0.0.0:443 0.0.0.0:* users:((“nginx”,pid=139556,fd=10),(“nginx”,pid=139555,fd=10),(“nginx”,pid=139554,fd=10),(“nginx”,pid=139553,fd=10),(“nginx”,pid=139552,fd=10))
nginx also uses this port

nginx 139553 www-data 10u IPv4 1699879 0t0 TCP *:443 (LISTEN)
nginx 139553 www-data 11u IPv6 1699880 0t0 TCP *:443 (LISTEN)
nginx 139553 www-data 12u IPv4 1699881 0t0 TCP *:80 (LISTEN)
nginx 139553 www-data 13u IPv6 1699882 0t0 TCP *:80 (LISTEN)
nginx 139553 www-data 14u IPv4 1699883 0t0 TCP *:4444 (LISTEN)
nginx 139553 www-data 15u IPv6 1699884 0t0 TCP *:4444 (LISTEN)
nginx 139554 www-data 10u IPv4 1699879 0t0 TCP *:443 (LISTEN)
nginx 139554 www-data 11u IPv6 1699880 0t0 TCP *:443 (LISTEN)
nginx 139554 www-data 12u IPv4 1699881 0t0 TCP *:80 (LISTEN)
nginx 139554 www-data 13u IPv6 1699882 0t0 TCP *:80 (LISTEN)
nginx 139554 www-data 14u IPv4 1699883 0t0 TCP *:4444 (LISTEN)
nginx 139554 www-data 15u IPv6 1699884 0t0 TCP *:4444 (LISTEN)
nginx 139555 www-data 10u IPv4 1699879 0t0 TCP *:443 (LISTEN)
nginx 139555 www-data 11u IPv6 1699880 0t0 TCP *:443 (LISTEN)
nginx 139555 www-data 12u IPv4 1699881 0t0 TCP *:80 (LISTEN)
nginx 139555 www-data 13u IPv6 1699882 0t0 TCP *:80 (LISTEN)
nginx 139555 www-data 14u IPv4 1699883 0t0 TCP *:4444 (LISTEN)
nginx 139555 www-data 15u IPv6 1699884 0t0 TCP *:4444 (LISTEN)
nginx 139556 www-data 10u IPv4 1699879 0t0 TCP *:443 (LISTEN)
nginx 139556 www-data 11u IPv6 1699880 0t0 TCP *:443 (LISTEN)
nginx 139556 www-data 12u IPv4 1699881 0t0 TCP *:80 (LISTEN)
nginx 139556 www-data 13u IPv6 1699882 0t0 TCP *:80 (LISTEN)
nginx 139556 www-data 14u IPv4 1699883 0t0 TCP *:4444 (LISTEN)
nginx 139556 www-data 15u IPv6 1699884 0t0 TCP *:4444 (LISTEN)

Is there any module which listens TCP/443 in /etc/nginx/modules-enabled?

not
it’s just the Jitsi app
this application uses port 443
the configuration that works
server {
listen 4444 ssl;
listen [::]:4444 ssl;
if I change
server {
listen 443 ssl;
listen [::]:443 ssl;

nginx does not start and I have this error
systemd[1]: Failed to start A high perform>

he has the same problem
and I see that it has no solution until now

What is the output for

grep 443 /etc/nginx/modules-enabled/*

grep 443 /etc/nginx/modules-enabled/*
/etc/nginx/modules-enabled/99-jitsi-meet-custom.conf: listen 443;
/etc/nginx/modules-enabled/99-jitsi-meet-custom.conf: listen [::]:443;

and the rest to the nginx virtualhost port.

you need a second FQDN for the turn server.

stream {
upstream web {
server 127.0.0.1:4444;
}
upstream turn {
server 192.168.2.56:5349;
}

map $ssl_preread_server_name $upstream {
    tun.xxxx.com         turn;
    default                 web;
}

server {
    listen 443;
    listen [::]:443;

    ssl_preread on;
    proxy_pass $upstream;

    # Increase buffer to serve video
    proxy_buffer_size 10m;
}

}

So your site already works on TCP/443. There is no problem to solve.

I changed it like this
server {
listen 4443;
listen [::]:4443;
I see it works now

Why…?
It already looks correct.

because if I install another virtual host in nginx
for example joomla
use port 4444
so now all applications use port 443
all i have in /etc/nginx/site-enable/…
now i use port 443
as is correct

I’m not sure I understand correctly. Normally you should add a new domain into 99-jitsi-meet-custom.conf as an upstream using a new port.

with this configuration everything I have in /etc/nginx/site-enable/…conf only works with port 4444

stream {
upstream web {
server 127.0.0.1:4444;
}
upstream turn {
server 192.168.2.56:5349;
}

map $ssl_preread_server_name $upstream {
    b.prs-calarasi.ro         turn;
    default                 web;
}

server {
    listen 443;
    listen [::]:443;

    ssl_preread on;
    proxy_pass $upstream;

    # Increase buffer to serve video
    proxy_buffer_size 10m;
}

}

but
with this configuration
everything I have in site-enable works with 443

stream {
upstream web {
server 127.0.0.1:4444;
}
upstream turn {
server 192.168.2.56:5349;
}

map $ssl_preread_server_name $upstream {
    b.prs-calarasi.ro         turn;
    default                 web;
}

server {
    listen 4443;
    listen [::]:4443;

    ssl_preread on;
    proxy_pass $upstream;

    # Increase buffer to serve video
    proxy_buffer_size 10m;
}

}

I don’t understand why either