Nginx not starting after debian and jitsi upgrade

I noticed an issue after upgrading my debian testing (bullseye), with jitsi installed from the apt repo “deb https://download.jitsi.org unstable/”. After upgrade, Nginx didn’t start anymore, with the following error: “nginx: [emerg] “load_module” directive is specified too late in /etc/nginx/modules-enabled/70-mod-stream-geoip.conf:1”. The issue was, that /etc/nginx/modules-enabled/60-jitsi-meet.conf comes before 70-mod-stream-geoip.conf, and that it contains server stanzas. Solution was to rename 60-jitsi-meet.conf to 80-jitsi-meet.conf. So if you landed here with your google search… Remember me in your prayers :wink:

1 Like