Nginx keeps haning on welcome

Hey Everyone,

I am struggling with the next thing.
I have set up the jitsi server successful with the next tutorial (https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md) .

After that, I started with https://github.com/jitsi/jicofo#secure-domain part.
Because I want to have the possibility for users (that are logged in) to make spaces and invite guests.

Steps I took:

1 In Prosody:

(If you have installed jitsi-meet from the Debian package, these changes should be made in /etc/prosody/conf.avail/[your-hostname].cfg.lua)

a) Enable authentication on your main domain:

VirtualHost "jitsi-meet.example.com"
    authentication = "internal_plain"

I have changed the authentication from the virtual host file to this.

b) Add new virtual host with anonymous login method for guests:

VirtualHost "guest.jitsi-meet.example.com"
    authentication = "anonymous"
    c2s_require_encryption = false

I added this line on the bottom of the file

2 In Jitsi Meet config.js configure ‘anonymousdomain’:

(If you have installed jitsi-meet from the Debian package, these changes should be made in /etc/jitsi/meet/[your-hostname]-config.js)

var config = {
    hosts: {
            domain: 'jitsi-meet.example.com',
            anonymousdomain: 'guest.jitsi-meet.example.com',
            ...
        },
        ...
}

2 In Jitsi Meet config.js configure ‘anonymousdomain’:

(If you have installed jitsi-meet from the Debian package, these changes should be made in /etc/jitsi/meet/[your-hostname]-config.js)

var config = {
    hosts: {
            domain: 'jitsi-meet.example.com',
            anonymousdomain: 'guest.jitsi-meet.example.com',
            ...
        },
        ...
}

The problem I am now facing is that the guest page cannot be found by Nginx (since the config is not updated / also no let’s encrypt certificate is available). Did I miss a step?

That’s correct - it’s just an internal domain for jitsi, not something you can visit m. Nginx knows nothing about it.

Restart jitsi-videobridge2 and Jicofo, then go to your normal domain, and try to start a conference:

Hey @Neil_Brown,

First of all thank you for the response.
Two questions.

How can I add an lets enscrypt certificate to my only members link


And the second, How disable I the possiblity for guest users to make a space / room?

There is no “members only” link. Everyone uses the same link/domain with secure config, and everyone gets promoted for a username and password.

Secure domain means only those with a prosody account can create a room - but anyone can join a created room.