New Webcam - Microphones blocked but not in Firefox or elsewhere

Til yesterday I used Jitsi meet with Electron and Chromium browser and with Firefox browser. The webcam was a Logitech C270.
Now I changed to Logitech C920 because of autofocus and better low light abilities. And then the problems started:

In Firefox I can allow / activate the webcam and its microphones and can choose between webcam microphone and another USB-microphone. Any test connections via Jitsi-meet were successfull.

In Jitsi meet electron and in Chromium, the webcam can be activated but there is no microphone to choose.
In both cases, I get an error message, that the microphjone is not accessable.

I have checked the webcam and its microphones with the program Guvcview and it showed up no problems. Further all system checks showed, that everything is OK and well working.

Any helpfull hints are welcome to solve this problem!

Do you happen to have another app using the Microphone?
Microsoft Teams in notorious for not letting go of the devices once it used them… I sometimes need to reboot!
(Assuming you are on windows… In linux, I can have 70 apps using the same inputs without issue)

Sorry, I have forgotten to mention:
I am on a Manjaro-Linux machine. It is allready checked with “System Profiler & Benchmark” and by listing all recording devices in terminal.
The main reason to use Linux is privacy concerns, als I am working as a Psychotherapist. Therefore it is a NoGo to use any Microsoft products like Skype or Microsoft Teams etc.

In case, that Firefox would be the programm, which blocks the microphone, then it is strange why it keeps blocked even after finishing Firefox or even after a restart of the system and chekcking again without having Firefox started.

Added: Just have checked the accessability of both microphones, recording with “simple screen recorder”. Here I can choose, whether I record from the summary pulse audio output or from either of both microphones. I could choose free any of these sources and record without any problems.

It seems, that the mircrophones are not blocked by any program.

Do a test on https://test.webrtc.org/ to troubleshoot.

1 Like

Also, in chromium based browser check the top bar to make sure you really have authorised Mic and Cam:

image

Of course I have tried already the suggestions, you have made, Freddie and Norman_Nadon:
Test.webrtc.org tells me: Failed to access your computer’s camera and microphone (NotReadableError: Could not start audio source).

This is similar to the message, I get from Jitsi-meet electron: Microphone: permission not allowed (or: access not allowed)

But when I try to access test.webrtc.org or any Jitsi-meet server via Firefox browser, I can not only successfully give access to the microphones of the webcam but I can also choose, which of the both microphones I want to use. (I have two microphones connected to my computer.)

This morning, I have started the computer and not using Firefox. Then tried again with Jitsi-meet electron and with Chromium browser and got the same bad results, as described above.

Once again I want to emphasize, that beside the effects I have described here already, all other programs on my computer do have full access to all audio and video sources with only one exception, which is Audacity. Audacity actually cannot access to any audio source, because no valid source is listed in its drop down list. It is obvious, that there is another bug to solve.

I understand your frustration, and for once, I cannot blame Jitsi-meet !
If you cannot use WebRTC in chrome or chromium based browser, there is something wrong with your system… The fact that audacity and electron-type apps can’t access it either confirms that…

I am a long time Linux user (and don’t own Windows computer anymore), and Manjaro looks and feels nice, but I got tired of patching-it up every time I wanted to achieve something… Give the Pop!OS live disk a try and report here please (no need to install it… just try it)
But in the end, I highly suspect that there is an issue with your Manjaro instance. (app permissions? driver issues?). Also, by default electron apps get lesser permissions, might look into that.

1 Like

No one wants to blame Jitsi and I won’t do so also! What a strange idea you put in here!

My idea behind asking here for helpfull tipps was the expectation, that someone perhaps has had a similar problem like that, I experience here.

When noone here will have a clue, then my assumption has been wrong and I will have to ask somewhere else. And my assumption has nothing to do with the quality of Jitsi.

@micro-user yeah, this is definitely not a Jitsi problem, so you’ll do better to check in other forums that may address your specific issue. An easy way to find out if anyone has reported the same or a similar problem is to do a quick search through the forum. I use the C920 camera (although I don’t use its audio) and it works fine for me. Jitsi Electron is based on Chromium, so it seems apparent the problem can be narrowed down to Chrome/Chrome-based browsers and applications. Check on Chrome/Chromium forums to see if anyone might have something useful.

No one wants to blame Jitsi and I won’t do so also! What a strange idea you put in here!

Maybe I told it in a weird way… I had a lot of issues related to Jitsi, the infrastructure itself, but what you are experiencing is not one of them! I probably lost a lot of hairs these past months with Jitsi, but it was worth it! It is an incredible project with talented and passionate devs…