New watermark not applied

Hello everyone,

I just try to replace the watermark in Jitis.
Based on some articles I am aware that it is /usr/share/jitsi-meet/images/watermark.png.
However when I replace it, it is not shown in the browser. Still the existing Jitsi logo appears. Restarting services and server wont help.

Can someone give me a nudge into the right direction here? What am I missing?


What happens if you visit your server via Tor Browser?

If you see the correct watermark, it probably means your usual browser is caching the old image.

1 Like

My bad, browser cache kicked in…

Thanks @Neil_Brown, I just discovered what you mentioned. Totally forgot about the browser cache. Works fine. Thank you for the hint

1 Like


1 Like

Maybe one last question, do you know how to modify the favicon?

If I modify the favicon.ico in the same directory and directly call it in my browser,, I still see the Jitsi one.
Can it be that it references to some other file?

If it’s not a caching issue; you could put your own favicon in /use/share/jitsi-meet/, then use your web server config to direct requests for /favicon.ico to your file.

Thank you. When I check the jitsi-meet site in nginx sites-enabled I dont see any default favicon.ico.
I assuem I will simply get this via:

location = /favicon.ico {
    alias /var/www/mysite/img/favicon.ico;

I was just wondering why the default configuration doesnt display the change of the file itself.
Will try it as you said, directly in nginx, thank you.

EDIT: Doesnt work, I still see the grey jitsi default icon. Strange… even though I moved it and replaced it in the images subfolder

EDIT2: Interesting, checking the website via, it previews the correct favicon now.
Opening it directly in my browser, still displays the old one.

EDIT3: TOR Browser displays the new favicon correctly. Brave not. For whatever reason that is…

Caching, at a guess!

Me too. Lets see when the cache times out.