New translation: Danish

I know that the guideline is to use the translate.jitsi.org but it does not seem to work for me. It times out.
So I have tried to translate the files manually.

I have made a quickinstall following the guide on Ubuntu 18.04 with Nginx preinstalled.
After that I git cloned the main repo to make some changes to the code and make/build them. That worked just fine and is running locally after moving the libs and lang files and the interface config files.
I have created new da files (3 files)

  • languages-da.json
  • countries-da.json
  • main-da.json

But the main files simply does not seem to want to take effect.
I have changed the defaultLanguage under /etc/jitsi/…-config.js

The language list under the Settings on the web app shows the languages in Danish. But the main-da.json (which is loaded in the network browser tab) does not work. (I have opened in an incognito window.)

A hint as to what I am missing or having a look at the translation.jitsi.org server would be greatly appreciated.

Thank you in advance.
Regards
Kenneth

A new translation server will be back online in the following months. Sorry about that. Till then, we will accept PRs for the files in the repo.
You need to define the language in https://github.com/jitsi/jitsi-meet/blob/master/lang/languages.json

Hi Kenneth,

Thank you for translating Jitsi Meet to Danish!

The pootle server is currently down. I think Damian is working on finding a solution, but we have a lot of other high priority tasks on our hands right now. Please hold on to your translation for now, we’ll be able to accept it later.

Regards,

Boris

How do I use these new language files?
I did add the language files on the server : https://github.com/kenneththorman/jitsi-meet/tree/master/lang. Did restart it. But I dont have the option to choose language.

I did try to edit the standart lang to danish as well.

Best regards,

You need to add it here: https://github.com/jitsi/jitsi-meet/blob/master/lang/languages.json and rebuild the sources, as this file is embedded in the app.bundle.

you make it sound so easy :slight_smile:
Are there any hint what I can search for to find a tutorial for this rebuild function.

Hi FroId

You can find the translations here. https://github.com/kenneththorman/jitsi-meet/commits/master
I have not made a push request since Boris said that the team was very busy.

Please bear in mind that if you are using the stable/4101 (the quickinstall version installed at least on Ubuntu but probably also on other OS’es depending on what repo you have connected) you code may look different)

But all in all

Copy the files from https://github.com/kenneththorman/jitsi-meet/blob/master/lang/

countries-da.json
main-da.json
languages-da.json
languages.json

Put them in your jitsi-meet install directory under the lang folder

Then locate the config.js file (which may or may not be located in you install folder, depending on if you have downloaded the sources or just the installed. This is most likely not the file you want to edit. There is a config in the Nginx config file that points the config to a file located under
/etc/jitsi/meet/YOUR_SERVER_NAME-config.js

In here you need to change the defaultLanguage to da and save the file

Regards
Kenneth

2 Likes

Make PRs with the translations.

PR added for review

2 Likes

Hi,

I have a custom jitsi meet installed on my Ubuntu server by following the Quick Install Guide (source repository). I would like to add few languages and remove some existing ones currently present by default(ie Jitsi currently supports 32 languages).

Based on the above reply I assume we
Cannot create respective countries-.json,main-.json,languages-*.json and add * in languages.json. and have multi linguistic feature available on my custom setup.

I see that we need to use translate.jitsi.org with Pootle user interface. But it is currently
down. Do we have a way to do it locally…

Also If I dont need few languages from the 32 listed , is there a way to disable them.

Regards,
Nithin