New installation participant video and camera is muted

Hi

When a new participant joins in after installation. i am seeing a strange behavior . The participant video is not seen and also his microphone is muted. Similarly for the participant the moderator video and microphoen is muted. Any config changes needed ?

The Lobby feature seems to be causing this issue not sure. Please guide .

Thanks
Naveen

Did you try the same thing with 3 participants? Same result?

Yes even for 3 partipants it is the same issue

Check your js console logs and also jicofo logs.

And prosody logs …

I have a similar problem. I installed jitsi on Ubuntu on a vm running on qemu/kvm. When we log in via our no-ip dynamic dns host name from inside our home network, everything works great.

However, when one participant is coming from outside we get exactly what is depicted in the OP’s screenshot. People inside the network can see each other but those on the outside network cannot participate. Everyone sees their own mic/camera as active and the mic/camera of those on the other network as muted.

Text chat however functions for everybody regardless of where they are.

I have not enabled port 5349 nor mapped it on the router as I am not really sure if it is essential. Is 5349 essential, could this be a symptom? If not, which log files should I be looking at?

I am a total newbie to this. First time I have ever tried to install a comms program of any kind.

Thanks.

  • Do the remote participants use the same dynamic dns host name or a different address?
  • Is UDP/10000 port accessable for the remote participants?

Yes, to the same dns name.
UDP/10000 is open in the server firewall as per install instructions and port forwarded on the router to the relevant IP which I believe means it must be accessible. (tested just now and it is open).

The remote participants can chat with the internal participants via the text chat.

@s.mag take a look at the Advanced configuration section of the Quick Install Guide. It might help to resolve your problem.

Could you share your /etc/jitsi/videobridge/sip-communicator.properties
mask your domain

I commented out the STUN mapping a short while. It seems to make no difference to this issue.

Thanks.

Hmmm just noticed the localhost entry. Could this be the significant error?

If you comment this line, JVB can’t publish its external IP to the remote clients.
Test with 3 remote participants after uncommenting this line (without a local participant)

Thanks.
Earlier in the week, before I commented that out I had two internal and one external participants.

I ran a test with it commented out just now and I saw no change with one internal and one external. I have reverted to the original already and changed the localhost name to the actual hostname. I haven’t had a chance to test that yet.


UPDATE.
Here is the current config. It seems to be working. However, I will need to do a further test to be convinced.

With this config I was able to have two internal users on the local wifi network connecting using the no-ip dynamic dns address.

I was also able to connection via the same dynamic dns address through a separate 3G network with two clients. And with one client on the 3G and the second on the wifi.

I will use my “volunteer” in another country tomorrow to further test it.

For some reason I cannot see this the screen shot even though it seems to have been uploaded.

Test it with 3 remote participants after uncommenting this line (without a local participant)
You can use 3 tabs on the same browser through a 3G connection

Just to confirm that the solution suggested worked. See screenshot.

I was able to do the following:

  1. Connect via 3G with with multiple tabs in the browser (firefox)
  2. Use video/vocie/screenshare with one participant in another country. In all cases using the NO-IP dynsname.

In case 2) I did notice that the video was suffering from either latency or bandwidth issues. However, I have experienced the same or worse with that particular person one Skype so it very likely is as a result of their connection rather than mine. I am looking forward to stress testing it soon with multiple users.

Thanks.

p.s. Domain name removed from screenshot.

Did you test a conference with 2 internal participant and 1 external participant?

Maybe you should add extra two lines to SIP config if there is a missing routing rule on your router.