New install of Jitsi Meet

I have installed Jitsi Meet on Ubuntu 18.04 Server. The install worked fine and even successfully installed the “Let’s Encrpyt” certificate. No errors at all.

Jitsi Meet works perfectly from inside my network. I have forwarded all the ports as described in the guide.

When I access Jitsi Meet from the WAN, I get the “Welcome to nginx” page. I have uninstalled Jitsi Meet and installed nginx first and then installed Jitsi Meet to try and correct this problem as indicated in posts from April. This does not correct the problem. I have also tried making the local and WAN address entries in /etc/jitsi/videobridge/sip-communicator.properties as indicated in the guide if I am behind a NAT. I still get the “nginx” welcome page.

Does anyone have any suggestions?

Do you use the same host address when connected from the WAN?
It seems that Nginx catches another host address.

@emrah Thanks, I got it working. The trick was that I needed to tell external users to use my WAN FQDN and not my dotted ip address. That worked interestingly.