Need to test that whether it's working or not after enabling OCTO / OCTO configuration

I did a normal Jitsi installation in one server. Now it includes jitsi meet Frontend, Prosody, Jicofo, and JVB. And then I did an additional JVB set up in a separate server. That flow is working without any issue.
Then I did the OCTO setup for both JVBs. In that, I applied a region named as region1 to the first JVB and second JVB region named as region2.
Then in jitsi meet frontend’s deploymentlnfo, I did the hardcore as region1.
But when I logged into the conference there’s region2 JVB to do the Jicofo identification.
I need to do the conference via the JVB that what I hard cored in the config file. If anyone has an idea about this matter, kindly request to give support.

Here is my first JVB configuration

Here are my second JVB configuration

Here is my jicofo configuration

And these are my frontend configurations

Here is the JVB log

Thank you very much.

I was in the same situation. So, I am waiting for answers from others. :grinning:

@teerayut Please share this post. I think we can get the answer asap.

Have you tried using public IP address in octo.BIND_ADDRESS? It might be work.

@teerayut You are saying that to apply the public IP instead of the private IP of that particular server. Isn’t it? I tried it now. But the issue is same.

your comments are messing up your configuration.
put the comments in new lines. and try again. I am not sure if this will fix the issue, but for sure its affecting your config.

Hi @creativeguitar,
Thank you very much. Finally, I was able to fix the issue. The issue was the issue of comments. My first step has already completed. Then I’ll try to route to the specific JVB according to the search GeoIP’s location. Again thank you very much.

1 Like

Hi @akalana,

Do we have to allow port 4096 in order to use OCTO? I already have a working multiple jvb but when i try to enable OCTO (following your step above) the JVB failed to connect to JMS.

I’m using the same region for both of my JVB (region1) and i’m using RegionBasedBridgeSelectionStrategy in jicofo settings.

Could you please share your succesfull step to make OCTO work?

Thanks

Hi @Access_Lab
If you need to check OCTO is successful work then follow these steps.

  • systemctl stop jitsi-videobridge2 on each jvb
  • apt install netcat if necessary.
  • On JVB1, start a netcat instance listening onport 4096 for UDP packets: nc -v -u -l -p 4096
  • On JVB2, attempt to connect to JVB1 nc -v -u -p 54321 internal-ip-of-jvb1 4096

Hi @akalana, thanx for your reply

Does your configuration on the top of thread work and successfully run OCTO?

@Access_Lab
Yes it works properly

hi there

can you please write up a guide for this and post ? it will be helpful for all

2 Likes

@masteryoda
Sure I ll do it

1 Like

Hi,
I have configured two Bridges and enabled OCTO. But Its working as load balancing but not as cascading. Conference is always connecting only one bridge. Please help.

Thanks
Santanu

1 Like