Need help with Dropbox integration

Hi @damencho Thanks for quick reply…I have used apt install jitsi-upload-integrations in the same server as jibri but nothing changed…do i need to enable this config, if ya then which one?

Do you have this in your jibri config:
"finalize_recording_script_path": "/usr/bin/jitsi_uploader.sh"?

no…cool…i will apply after this…

Thanks @damencho it worked perfectly…btw i think jitsi_uploader.sh requires jq as dependency…i mean i got an error jq: command not found at first so i installed that and then it worked properly…maybe u can add jq debian package deps

Hi @damencho thanks for sharing…one follow-up question, when I did the recording i realised there is a bug on the sound effect where by when user is using speaker there is 2 sounds in the recording as shown in the video link

I did this recording using meet.jit.si website…any advice on how to solve this issue, I mean where can I modify so the sound wont play for jibri?

One of them is coming from the mic and back to jibri, so there is nothing we can do, it is normal audio that needs to be recorded, if you use on that side headset it will not be recorded.
But I agree that we can remove the audio played on the jibri side, I will check it these days.

1 Like

Hi…I was able to make it work without any plugin and js sdk. The first step is to use a link to the authorize and redirect to another page when user accept (this is the redirect uri). In this page keep it empty, but create a flow on page load that will grab the CODE from url. Call the Token endpoint.

Hello,

I have a working jitsi-meet on my server and am exploring the possibility of uploading recordings of my own sessions.
I have both a dropbox as well as a youtube uploading users setup.

My installation (on ubuntu 18.10) of jitsi-meet has been done through apt-get, so I have the stock installation and apt-get does not know about “jitsi-upload-integrations” packages (unable to locate package) .

Would it be a sin to go to git, download it from there and execute the install script?

Many thanks in advance

Pardon, it was on 16.04, not 18.10

Nope it is fine. The package is available only in the unstable repo for now, but you are using the stable one.

Hi @damencho I tried to use apt install jitsi-upload-integrations but it said unable to locate package. Is there a repo to add?

unstable

For me, I have cloned the jitsi-upload-integration repo and configured the script path jitsi-upload-integrations/jitsi_uploader.sh to /etc/jitsi/jibri/config.json.

Then restarted jibri service jibri restart.

I already have the dropbox app created and the key added to jitsi-meet config.

The recording is being saved with meta to the server path given but it is not uploading to the dropbox.

The log file jibri-log.txt (12.7 KB) says "No upload type found, skipping upload...".

Do I need to change something?

Environment Details:

  • Jitsi: Quick Install - with jitsi-meet from Github master
  • OS: Ubuntu 16.04.6 LTS (GNU/Linux 4.4.0-176-generic x86_64)
  • Prosody: 0.9.10-1
  • Jibri: 8.0-14-g0ccc3f6-1
  • Jicofo: 1.0-549-1
  • Nginx: 1.10.3-0ubuntu0.16.04.5
  • JVB: 2.1-183-gdbddd169-1

Configured dropbox token by running ./jitsi-upload-integrations/dropbox/dropbox_uploader.sh. (generated app token and passed here)

And even tried to compile and install the upload script from source.

cd jitsi-upload-integrations
sudo apt-get install devscripts
debuild -b -uc -us
cd ..
sudo dpkg -i jitsi-upload-integrations_0.0.1-1_all.deb

But this didn’t ask me for any input.

Can you please share jibri logs?
In my case it was showing /jibri/jitsi_uploader.sh: line 34: jq: command not found
after that I installed jq

sudo apt-get install jq

then it was showing line 76: /usr/bin/dropbox_uploader.sh: No such file or directory
I changed BIN_PATH in jitsi_uploader.sh

I have shared the log there. For me the dependencies are installed in advance and it looks fine till upload type.

No upload type found, skipping upload...

You may be interested to try this approach: How-to to get a WORKING setup of Google Drive, One Drive or other cloud services in Jibri, my comprehensive tutorial for the beginner I describe in detail a setup that uses a slightly different -but more flexible- approach.

Several users in the community have confirmed this worked well for them.

thanks :slight_smile:

jitsi_uploader.sh needs CONFIG_FILE_PATH="/etc/jitsi/uploader" but what to put in there ? There is none installed with the debian package and couldn’t find any sample googling.