Need help in applying “muc_owner_allow_kick.patch” in prosody version 0.11.9

I installed all owner module to my prosody but i wanted to apply muc_owner_allow_kick patch
sudo patch -b </usr/share/jitsi-meet/prosody-plugins/muc_owner_allow_kick.patch showing sending this patch to rejected . is their any other way to do this…?

Where are you running that command? Try cd to /usr/lib/prosody/modules/muc before running that. So:

cd /usr/lib/prosody/modules/muc
sudo patch -b < /usr/share/jitsi-meet/prosody-plugins/muc_owner_allow_kick.patch

yes running in the same folder

Showing this error

patching file muc.lib.lua
Hunk #1 FAILED at 1256.
1 out of 1 hunk FAILED – saving rejects to file muc.lib.lua.rej

To quickly change the a topic for a while, is upgrading to prosody 0.11.12 an option for you? If you can, it would remediate CVE-2022-0217 for you, and if the patch still fails we can revisit.

Back to your specific issue, it looks like it is matching the wrong line.

Try this patch: muc_owner_allow_kick_0-11-9.patch · GitHub

nope same error

currently we cannot update the server

can you upload your /usr/lib/prosody/modules/muc/muc.lib.lua file somewhere so I can try the patch?

This worked actually.thanks @shawn

Cool. The official one? or the custom one I posted above?

custom one you posted

Awesome. Glad it worked for you. Happy mod-kicking :slight_smile:

yea thanks also you solved a really big problem