Navigation link in "participants"- button broken after usage of lobby chat

I discovered this behaviour after installing the latest stable. For the sake of simplicity I’ll be using meet.jit.si as a reference.

Steps to reproduce:

  • Browser: Chrome 104.0.5112.79 (Official Build) (64-bit) (- but applies to all browsers I tested)
  • Create meeting at meet.jit.si
  • Moderator enables Lobby
  • First Participant arrives

Screenshot from 2022-08-16 21-08-12

  • Using the Lobby Chat Feature, the moderator asks something (“Chat”)
  • After that, a click from the moderator on the “participants” button (picture below), i.e. to see who else is waiting in the lobby, redirects to “/static/close3.html”, which throws the moderator out of the meeting. End of game.

Screenshot from 2022-08-16 20-53-02

Additional observations:

  • After the second participant has joined the meeting, the “Chat” link is missing from the notification Window

Screenshot from 2022-08-16 21-05-38

The moderator now has to use the function to the top right of the window

Screenshot from 2022-08-16 21-02-03

… with the same result (link “Chat” throws him out of the meeting).

Fun Fact:
If you once had people in your room, and they all left, and you are alone, and THEN another participant arrives, the chat-link-missing pop up stays chat-link-missing. Maybe this observation is of importance.

2 Likes

Thanks for the report! Fix: fix(participants-pane) fix button impport by saghul · Pull Request #12033 · jitsi/jitsi-meet · GitHub

So this should be now in the actual stable, right? I don’t know if it is my fault (it’s early in the morning), but from what I see the problem remains (click the “Chat” link in the top right of the windows, last screenshot from previous post, throws you out of the room) .

The PR just landed, which means that it’s available in alpha.jitsi.net, but not in any stable release yet.

Lobby Chat Feature doesn’t work on meet.jit.si and alpha.jitsi.net - guest just seen black screen when moderator lobby chat started.
And one more bug: When i disable this feature on my own installation

enableLobbyChat: false

Moderator can’t view lobby - get black screen if we have more than one guest not approved. If we click on view lobby button - got black screen.
image

Nice find! Fix coming right up!

I cannot reproduce this, I get this:

Can you reproduce it on alpha?

Fix for the first: fix(lobby) fix opening lobby chat after API change by saghul · Pull Request #12117 · jitsi/jitsi-meet · GitHub

i see that lobby chat enabled on alpha, so it is not reproducible (

But you can disable it by appending #config.enableLobbyChat=false to the URL.


lobby chat is still enabled

YOu need to add it before joining the meeting, sorry I was not specific.

1 Like

image
It is ok. On alpha.jitsi.net is not reproducible this bug - lobby is worked in any case.

Excellent. The fix will be part of the next release.

2 Likes