NAT related connection issue

meet
#1

Hello,

I installed Jitsi Meet on my Ubuntu 18.04 server. I used your debian repository to install it. The server is behind NAT and use a local IP. TCP ports 80-443-4443 and UDP port 10000 are open on the firewall. I added theses line in /etc/jitsi/videobridge/sip-communicator.properties:

org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=10.x.x.x
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=64.x.x.x
org.jitsi.videobridge.TCP_HARVESTER_MAPPED_PORT=4443

I tried with and without the last line, not sure if it’s required.

It works fine for users on the same network, but external users can’t publish or receive media (webcam, shared screen).

Did I forget to do something?

Thanks

#2

Have you forwarded the ports from the router (64.x.x.x) to 10.x.x.x?

#3

Yes

#4

If you are sure that forwarding is fine, you need to check whether jvb sends you the correct addresses and ports by opening chrome://webrtc-internals before creating a conference with 3 participants and check the last setRemoteDescription.

Need help I can´t see video in dns just internal
#5

What lines should I look? I see theses strange lines about IP 0.0.0.0 instead of my real IP. Is it the right line to look? If yes, what can cause that?

cat webrtc-internals.txt | grep IP4
o=- 1923518516 2 IN IP4 0.0.0.0
c=IN IP4 0.0.0.0
a=rtcp:1 IN IP4 0.0.0.0
c=IN IP4 0.0.0.0
a=rtcp:1 IN IP4 0.0.0.0
c=IN IP4 0.0.0.0

#6

Here is an example that I just took from meet.jit.si:


You can see a=candidate… udp … address port …
You maybe looking at the p2p peerconnection…

#7

Seem like the IP4 0.0.0.0 is normal becuase you also have it in your sample.

I found the correct line and I can confirm it publish the local IP instead of the public one I configured.

cat webrtc-internals.txt | grep candidate
a=candidate:1 1 ssltcp 2130706431 10.5.0.26 4443 typ host generation 0
a=candidate:3 1 udp 2130706431 10.5.0.26 10000 typ host generation 0
a=candidate:1 1 ssltcp 2130706431 10.5.0.26 4443 typ host generation 0
a=candidate:3 1 udp 2130706431 10.5.0.26 10000 typ host generation 0
a=candidate:1 1 ssltcp 2130706431 10.5.0.26 4443 typ host generation 0
a=candidate:3 1 udp 2130706431 10.5.0.26 10000 typ host generation 0

The IP 10.5.0.26 is the server local IP.

#8

So apparently this setting for some reason did not took effect. Did you restart jvb after editing the file?
Give some time for jicofo to discover the jvb after the restart or just restart and jicofo after jvb.

#9

Mmm I was sure I had completely rebooted the VM after changing that settings. Seem like I didn’t. I rebooted the VM for real this time and this work fine!

Thanks for your help anyway!

#10

In this particular screenshot, i see that only UDP is showing up. Does that mean that on meet.jit.si TCP is disabled?

Best,
Sanjay