Name of caller not being displayed for incoming calls

Hi community,
there are several old threads regarding this issue but I didn’t find a solution there.
For incoming calls there is only the phone number being displayed, in the popup window as well as in the history. I didn’t find anything in the setting that fixes it.
Best regards - Ulrich
I’m on windows 10.