My logo does not appear if I change it to the original

Hello, I have put a customized drawing, both in .svg and in .png, I have put it in the folder
/usr/share/jitsi-meet/images
and then I changed in:
/usr/share/jitsi-meet/interface_config.js
the two watermark.svg for my icon, but it does not appear, the icon is there but my image does not load, and in the inspector,
if it is trying to read my icon but when I press it it appears:
The image in the XXX path cannot be displayed because it contains errors.

Sorry, not quite sure I understand what you mean by this. Are you saying you changed the names of the images in interface_config.js?


The first thing I did was replace the watermark.svg in the images folder with my renamed file watermark.svg and it doesn’t load, the invisible image appears

then change in interface_config.js the line where it says watermark.svg to watermark.png and I put a watermark.png file in the images folder and it doesn’t work either…



Just a guess, but looks to me like your SVG file is corrupted. If you download https://<yourdomain>/images/watermark.svg, are you able to view the image?

yes, and I have tried with a file created by me and another of a colleague, created by him but the same result…

on the server I get the file from drive with the command wget “url” -O watermark.svg

Did you try viewing in incognito (private) mode? Does it show up?
It could also be that the file is too large.

well nothing worked for me…
They passed me a link with the image uploaded to the server and editing the file
/usr/share/jitsi-meet/interface_config.js
change drawing path to access from external url path

DEFAULT_LOGO_URL: 'https://myserver.com/static/watermark_4c.svg',
DEFAULT_WELCOME_PAGE_LOGO_URL: 'https://myserver.

com/static/watermark_4c.svg’,

thz