My Jitsi Server vs Jitsi Production missing Launch in Web

I am seeing a discrepancy between my server and the Jitsi production server.
I ran an update on my Ubuntu Jitsi server with:

apt-get update
apt-get install jitsi-meet

Then I opened jitsi meet via the URL on my iPhone but I am not seeing the button for “Launch in Browser”. Shouldn’t I see it if I have the latest installed?

You might be running an old version of the JMS.
Check if that’s the case or maybe it got removed manually on your instance.


apt-get install jitsi-meet

doesn’t update to the latest Jitsi Meet Server?

Try apt-get update && apt-get upgrade jitsi-meet instead?

You double check the versions you have with dpkg -l | grep jitsi. As of now, you should see jitsi-meet 2.0.5765-1 if you’re using the stable packages.

Related post: [How to] How to upgrade Jitsi Meet & Monitor the logs

Thanks, I gave that a try and also tried:

apt-get --with-new-pkgs upgrade

from the link you supplied. I saw it updating but it looks like the version is still 2.0.5390-3

Below is the output from dpkg -l | grep jitsi

I am on Ubuntu 20.04.2 LTS if that matters.

ii jitsi-meet 2.0.5390-3 all WebRTC JavaScript video conferences
ii jitsi-meet-prosody 1.0.4628-1 all Prosody configuration for Jitsi Meet
ii jitsi-meet-turnserver 1.0.4628-1 all Configures coturn to be used with Jitsi Meet
ii jitsi-meet-web 1.0.4628-1 all WebRTC JavaScript video conferences
ii jitsi-meet-web-config 1.0.4628-1 all Configuration for web serving of Jitsi Meet
ii jitsi-videobridge2 2.1-416-g2f43d1b4-1 all WebRTC compatible Selective Forwarding Unit (SFU)

That’s strange. I presume you did run apt-get update before the upgrade? 2.0.5390-3 is from January so not the latest.

What do you see when you run: apt-cache policy jitsi-meet | head

and then do apt update.

If the sources file is different, then probably you installed using the old instructions and this will help wget -qO - | apt-key add -

1 Like

I was able to upgrade using the above suggestions along with this:

Thanks for the help!