My clean instalation on Ubuntu doesn't run as meet.jit.si

Hi all, I’m new on jtisi, I have a clean instalation on Ubuntu server and when I test the environment doesn’t run as expected. In meet.jti.si I can create a room and I can enter in it with Chrome and Firefox without problems. In my clean instalation I can only enter to rooms with Chrome, when I enter with Firefox, the video of all participants stop. The same happens when I enter with Chrome throught a Mac.
Can you tell me where can I config the server to have the same behavior as yours. I’ve found the file “jitsi.inxpirius.com-config.js”, but I don’t if it is the rigth place to config and what I have to set.

Many thanks in advance.

Regards
PD: Congratulations for this development, it’s amazing.

Try disable H264 in the config.js, many chrome browsers still have trouble decoding H264 video. Firefox may try to use hardware accelerated H264.

disableH264: true,

Thank you very much for your fast answer. Chrome within Mac is running now, but I still have the problem with Firefox.

What kind of problem do you have with firefox?

A know issue with firefox is that firefox only send the full webcam video resolution, thus if a firefox user connects and have a HD webcam then that user starts to send 3Mbit/s video to all participants. Is the problem that bandwidth is too high for chrome users when firefox join?

Ok, but when use meet.jit.si server I can enter with firefox without problem. How can I limit bandwith int he config.js file.
The problem is: when I enter the room, video of all participants stop.

And other problem I’ve noticed, when I have two Chrome participants in a room, everything it is ok. When third enters with Chrome, all videos stop again.

Regards

with 3 users jitsi switches from direct p2p mode to using the videobridge.

It sound like you have a misconfigured videobridge:
check the /var/log/jitsi/jvb.log and the /var/log/jitsi/jicofo.log and make sure the videobridge connect and work.
If your videobridge server is behind a NAT then make sure you have updated
/etc/jitsi/videobridge/sip-communicator.properties
https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md#advanced-configuration

to ease debugging of the videobridge issues you can disable the p2p mode entirely so that all conferences uses the videobridge even with two users.
p2p: {
enabled: false,
}

Thank you very very much, I’ll check and try what you said.

Regards

1 Like

you can compare your configuration with the configuration on meet.jit.si in order to see what differs.
https://meet.jit.si/config.js
https://meet.jit.si/interface_config.js

1 Like

Thank you for your support, it’s so useful. The problem was in videobrige because we hadn’t opened all necessary ports. We hadn’t have our server behind a NAT.

Will jitsi be compatible with IE11 in the future?
Are the chat messages stored in anyplace so we can query them?

Regards

1 Like

When Microsoft implement webrtc support in IE then it is compatible. It may be possible to install a webrtc plugin for IE11.
https://temasys.io/products/temasys-webrtc-plugin/

Microsoft have started to use chromium code in their EDGE browser so EDGE based on chromium may support webrtc.

you can check webrtc support here: https://test.webrtc.org/ if the webbrowser pass the test jitsi should work ok.

You can configure or write a muc plugin the prosody XMPP server.

a quick install of jitsi setup the prosody XMPP server to be configured to store the chat messages in memory, the messages are removed when the last user leavs the chat. You can configure prosody to store permanent by modify the prosody configuration here:
/etc/prosody/conf.d/*.cfg.lua

read the prosody documentation available: https://prosody.im/doc
documentation about chat logging: https://prosody.im/doc/archiving

Many thanks. We will try both solutions and I tell you how it went.

Regards