My apache2 virtualhost confoguration was deleted/overwritten by a new jitsi one!

Followed the standard install of jitsi meet and apparently my vistual host apache2 config was overwritten! Does the install make a backup somewhere?

found my old config here: /var/lib/letsencrypt/backups/ but not the good one
How can this happen?
During installation I thought I need to fill-in my hostname which is mydomain.com without meet or anything.

(I am reading the install for the 4th time btw)

Should I had to add as hostname www.mydomain.com/meet ?

I already have my server and multiple application running behind my apache2 with lets encript

It is not so clear for me how to get meet in the following way:

What do I need to change the the default configuration? Also I already have a working lets encript on www.mydomain.com the reson is that all my applications are server by just one lets’s encript. So i do not want subdomains but www.mydomain.com/meet and whatnot

Your config was not overwritten by jitsi software per se but by certbot, the Lets’encrypt client that Jitsi-meet server uses to get a valid certificate. As far as I can tell, the use of Let’sEncrypt is optional in the jitsi-meet installation process. When you accept it, certbot does its thing and it is not always successful at keeping a working config.
It’s not clear to me what is the ‘standard’ install since it has completely changed after 31/3 at least on Debian derivatives (use of videobridge v2). If you have v2, it uses nginx and afaict there is no way to disable it. However in this case what you could do is to add a section in the nginx file to make it listen on http on a port you pick and to do a classical https reverse proxy in Apache config, with your good Let’sEncrypt certificate.
After that, you can do what you want with your Apache config, either mydomain.com/meet or meet.domain.com, whatever.