Muted Video track is not getting distributed to participants

Hi,
I am using lib-jitsi-meet to create custom UI for conference.

I have found one strange behavior, If I create track, then call track.mute() before room.addTrack is being called, then
On track creation logged Mediastream(track[1].stream) stays active:false
AND
after joining the conference I am getting track.stream =null

In Jitsi-Meet UI, I can see video and audio mute buttons are disabled till we join the room. Is this how behavior should be? What should be done If I want to enter room being muted but this setting shouldn’t be for all participants(START_MUTED_POLICY).

Or am I doing something wrong here.

Additional logs on console :

JingleSessionPC[p2p=true,initiator=true,sid=0a726a30b17f] - some SSRC were added on addTrackUnmute