Multiple moderators in one meeting

Sorry I took so long to answer!
What you experience is the normal behaviour of jitsi on a secure domain
1- First person to create a room has to authenticate as a moderator
2 - All subsequent people added to the same conversation are guests, unless they had previously logged as a moderator on your site.
3 - If a guest in the room wants moderator priviledges, he/she has to click on the three dots on the bottom right of the screen, then select settings. In the settings, in the profile tab, there is a field for the display name and at the bottom a login button. If the person logs with the prosody credentials there, he/she will also be a moderator. This is retained for future sessions on jitsi on the same computer and browser.

I can show you on my own instance if needed

1 Like

Thanks for all replies.
Normand_Nadon solution worked.

1 Like

Hello sir can you help me how to set this up…i have self hosted jitsi in linux vm and use it as an iframe.

How to do that??

Hi @masteryoda,
I also have same requirement as yours, were you able to find solution for multiple moderator logins. I see there is option in settings for login but when I click on it, nothing happens.

Please share if you were able to solve this or if anyone one of you guys have any ideas.

Thanks,
Sangram

Have you setup your instance with secure domain?
What type of authentication do you want to do?

yes, I have setup secure domain and I want multiple moderator to login after the meeting is started as sometimes the main moderator is disconnected and then could not join back as moderator but guest, so in that case I want moderator to login again and I see option to login in settings but not sure how to enable it.

image

Join as Guest and then try to login, it doesn’t work

Did you create your user in prosodyctl?

Yes, I have

Are you able to create a new meeting without logging as a moderator? If so, you have not set your instance correctly!

I think you did not get me, I have setup correctly and I also have to login as moderator for starting any meeting but when I am as moderator gets disconnected from the meeting and other participants are still there in the meeting, now I tried to join the meeting again but I am not moderator anymore so now I want to login as moderator and the login option doesn’t work here.

Hello @SANGRAM_BHAVAR,

I enabled the JWT authentication but also allowed the guest login without a token for some of my servers. The token_affiliation module is enabled for these servers too.

The authorization works as expected when the participants have no token. But if a participant has a moderator token, she becomes always moderator for each login. No need to be the first participant…

1 Like

You did something wrong my friend… This is not an issue I had and I have been using secure domain from day 1, on 4 different instances, in docker and bare metal installs with several updates over the last 6 months. I had other problems, a lot of them, but this is not one of them!

What version of jitsi-meet do you use? Do you use the regular “stack” or some other means of reverse-proxies and systems? What is the OS under the stack?

1 Like

Hi @Normand_Nadon, Thanks for your help. Please find the version details

ii  jitsi-meet                           2.0.5142-1                        all          WebRTC JavaScript video     conferences
ii  jitsi-meet-prosody                   1.0.4466-1                        all          Prosody configuration for Jitsi Meet
rc  jitsi-meet-tokens                    1.0.1-1                           all          Prosody token authentication plugin for Jitsi Meet
ii  jitsi-meet-web                       1.0.1-1                           all          WebRTC JavaScript video conferences
ii  jitsi-meet-web-config                1.0.1-1                           all          Configuration for web serving of Jitsi Meet
ii  jitsi-videobridge2                   2.1-376-g9f12bfe2-1               all          WebRTC compatible Selective Forwarding Unit (SFU)

I am using customized *-web and *-web-config module for UI. I am using regular stack

this is the OS
    5.4.0-52-generic #57-Ubuntu SMP Thu Oct 15 10:57:00 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

There is no issue with the current system, only thing is that I want to login using login button as moderator after the meeting is started.

Thank you for your patience

@emrah, Would you please share how did you enable the JWT authentication.

Thank you so much for your reply!

If your system is Debian 10, check this post

If your system is Ubuntu 20.04, check this post

After enabling the token authentication, check this topic to see how to enable the Token Affiliation module

Unlike these, enable allow_empty_token in the Prosody config too and don’t disable org.jitsi.jicofo.DISABLE_AUTO_OWNER in /etc/jitsi/jicofo/sip-communicator.properties

1 Like

Thank you! I am trying this.

Hello

i have a similar issue , but instead of being limited to one moderator everyone who joined my room are moderator…

    admins = {
    "focus@auth.MYDOMAIN.COM",
    "jvb@auth.MYDOMAIN.COM",
    "superman@MYDOMAIN.COM"
}

    plugin_paths = { "/prosody-plugins/", "/prosody-plugins-custom" }
        http_default_host = "MYDOMAIN.COM"

consider_bosh_secure = true;

cross_domain_websocket = { "https://MYDOMAIN.COM" }
cross_domain_bosh = { "https://MYDOMAIN.COM" }


VirtualHost "MYDOMAIN.COM"

    authentication = "token"
    app_id = "my_jitsi_app_id"
    app_secret = "JWT_SECRET"
    allow_empty_token = true

    ssl = {
        key = "/config/certs/MYDOMAIN.COM.key";
        certificate = "/config/certs/MYDOMAIN.COM.crt";
    }
    modules_enabled = {
        "bosh";
        "pubsub";
        "ping";
        "admin_rest";
        "speakerstats";
        "conference_duration";

    }

    speakerstats_component = "speakerstats.MYDOMAIN.COM"
    conference_duration_component = "conferenceduration.MYDOMAIN.COM"
    muc_room_default_moderated = true
    c2s_require_encryption = false


VirtualHost "guest.MYDOMAIN.COM"

    authentication = "token"
    app_id = "my_jitsi_app_id"
    app_secret = "JWT_SECRET"
    c2s_require_encryption = false
    allow_empty_token = true


    modules_enabled = {
        "muc_lobby_rooms";
    }
    muc_room_default_moderated = true
    main_muc = "muc.MYDOMAIN.COM"
    lobby_muc = "lobby.MYDOMAIN.COM"
    muc_lobby_whitelist = { "recorder.MYDOMAIN.COM" }


VirtualHost "auth.MYDOMAIN.COM"
    ssl = {
        key = "/config/certs/auth.MYDOMAIN.COM.key";
        certificate = "/config/certs/auth.MYDOMAIN.COM.crt";
    }
    authentication = "internal_hashed"


VirtualHost "recorder.MYDOMAIN.COM"
    modules_enabled = {
      "ping";
    }
    authentication = "internal_hashed"


Component "internal-muc.MYDOMAIN.COM" "muc"
    storage = "memory"
    modules_enabled = {
        "ping";

    }
    muc_room_locking = false
    muc_room_default_public_jids = false

Component "muc.MYDOMAIN.COM" "muc"
    storage = "memory"
    muc_tombstones = false
    restrict_room_creation = "local"
    modules_enabled = {
        "muc_meeting_id";
        "token_verification";

    }
    muc_room_cache_size = 1000
    muc_room_locking = false
    muc_room_default_public_jids = false
    muc_room_default_moderated = true

Component "focus.MYDOMAIN.COM"
    component_secret = "FOCUS_SECRET"

Component "speakerstats.MYDOMAIN.COM" "speakerstats_component"
    muc_component = "muc.MYDOMAIN.COM"

Component "conferenceduration.MYDOMAIN.COM" "conference_duration_component"
    muc_component = "muc.MYDOMAIN.COM"


Component "lobby.MYDOMAIN.COM" "muc"
    storage = "memory"
    restrict_room_creation = true
    muc_room_locking = false
    muc_room_default_public_jids = false

here is my jitsi-meet-cfg.lua

my current setup was working before i update all jitsi component

room can only be created with a jwt token, people with jwt token can create room or being moderator if already exist
people without jwt can join a already created room without being moderator

this config worked since 2019, last week i have updated all jitsi component ( yeah many many updates ) and now when people join a room they are moderator even with jwt token