Multi-person access

meet

#1

I originally thought that I deployed the server, but I had some trouble with it. Here are three examples to express my problem.

  1. On my own computer, I opened 3 windows in the same room with chrome, they are all working normally.
  2. My colleague and I met in the same room (only two people) and worked normally.
  3. My colleagues and I met in the same room (3 people) and lost contact with each other.
    I don’t know what went wrong, the server is deployed on my computer, I am using docker-jitsi-meet.

#2

With 2 people you are connecting in p2p mode, seems for some reason you cannot access jvb, either its advertising wrong address or you cannot access its ports.


#3

Thank you for your reply,

I did not configure ip to the server in advance, I refer to the env.default file.
Then I modified config.js (note the address of the turn server), now to make sure I am under jvb, I modified it again and restarted the server, now it is like this,

[p2p: {

Enabled: false,
// Use XEP-0215 ​​to fetch STUN and TURN servers.
// useStunTurn: true,
…]

I started the multiplayer test on my computer again (including 3 chrome windows, the lenses are me, they all work fine).

After modifying the p2p mode, I asked my colleague to talk to me, but failed (he lost the connection), it seems to work well on my computer (two or more people), but there will be problems in other people’s computers ( We can talk before disabling p2p ).

I don’t confirm if this is a problem with jvb access, but on my own computer, everything is ok. I have not modified the port.

I modified the startup order of docker-compose.yml, because at the time I found that some startup order would make the server not find jvb (my chrome console reported this wrong), then I tried to record The order in which the service can be used normally, and finally it becomes like this [
Starting dockerjitsimeet_prosody_1 …
Starting dockerjitsimeet_prosody_1 … done
Starting dockerjitsimeet_web_1 …
Starting dockerjitsimeet_web_1 … done
Starting dockerjitsimeet_jicofo_1 …
Starting dockerjitsimeet_jicofo_1 … done
Starting dockerjitsimeet_jvb_1 …
Starting dockerjitsimeet_jvb_1 … done
] And at the time I had no problem on my computer, no matter talking in p2p or more people .

Where have I done something wrong or where else I have not done it? Looking forward to your reply, Happy Lantern Festival.