Muc_max_occupants Make XMPP not work properly

I added the following configuration using prosody 0.10.0-1 build1

plugin_paths = { "/usr/share/jitsi-meet/prosody-plugins/" }
muc_max_occupants = 2
muc_access_whitelist = { "focus@auth.jitsi.example.org"}
muc_room_cache_size = "1000"

I use prosody 0.10.0-1build1 to add the following configuration.
Unfortunately, he is invalid settings.
I found many problems in community that is prosody version.
prosody-trunk_ 1nightly747-1_ xenial_ AMD64
unfortunately, the following error occurred in booting prosody and cannot continue

Sep 10 16:39:46 c2s5572d01186a0	error	Traceback[c2s]: /usr/lib/prosody/util/cache.lua:66: table index is nil
stack traceback:
	/usr/lib/prosody/util/cache.lua:66: in function 'set'
	/usr/lib/prosody/modules/muc/mod_muc.lua:177: in function 'track_room'
	/usr/lib/prosody/modules/muc/mod_muc.lua:205: in function </usr/lib/prosody/modules/muc/mod_muc.lua:192>
	(...tail calls...)
	/usr/lib/prosody/modules/muc/mod_muc.lua:434: in function '?'
	/usr/lib/prosody/util/events.lua:79: in function </usr/lib/prosody/util/events.lua:75>
	(...tail calls...)
	/usr/lib/prosody/core/stanza_router.lua:180: in function 'core_post_stanza'
	/usr/lib/prosody/core/stanza_router.lua:127: in function 'core_process_stanza'
	/usr/lib/prosody/modules/mod_c2s.lua:275: in function 'func'
	/usr/lib/prosody/util/async.lua:127: in function </usr/lib/prosody/util/async.lua:125>

I continue to change the version of prosody to 0.11.6-1 ~ bionic1.

After restarting prosody, it is very good.

He can limit the number of people in the room normally.

Unfortunately, after a few minutes, he still made the following errors when entering the room.

Can anyone help me? I have no idea now

Sep 10 16:39:46 c2s5572d01186a0	error	Traceback[c2s]: /usr/lib/prosody/util/cache.lua:66: table index is nil
stack traceback:
	/usr/lib/prosody/util/cache.lua:66: in function 'set'
	/usr/lib/prosody/modules/muc/mod_muc.lua:177: in function 'track_room'
	/usr/lib/prosody/modules/muc/mod_muc.lua:205: in function </usr/lib/prosody/modules/muc/mod_muc.lua:192>
	(...tail calls...)
	/usr/lib/prosody/modules/muc/mod_muc.lua:434: in function '?'
	/usr/lib/prosody/util/events.lua:79: in function </usr/lib/prosody/util/events.lua:75>
	(...tail calls...)
	/usr/lib/prosody/core/stanza_router.lua:180: in function 'core_post_stanza'
	/usr/lib/prosody/core/stanza_router.lua:127: in function 'core_process_stanza'
	/usr/lib/prosody/modules/mod_c2s.lua:275: in function 'func'
	/usr/lib/prosody/util/async.lua:127: in function </usr/lib/prosody/util/async.lua:125>

Your problem is the storage setting, this is normally taken care on install time, but if you move between versions of prosody after installing jitsi-meet, this is a manual process.


Prosody nightly747 storage = "null"
Prosody 0.10 storage = "none"
Prosody 0.11 storage = "memory"

Thank you for your answer. Unfortunately, I have manually specified

Component "conference.jitsi.example.org" "muc"
    storage = "memory"
    modules_enabled = {
        "muc_meeting_id";
        "muc_domain_mapper";
        -- "muc_allowners";
        -- "token_verification";
        "muc_max_occupants";
    }
    muc_max_occupants = "3"
   muc_access_whitelist = { "focus@auth.jitsi.example.org"}
   admins = { "focus@auth.jitsi.example.org" }

But the above situation still happened, so I don’t think this is the answer to the question

This for prosody 0.11? Check whether there are more places with storage config.

this is Prosody 0.11.6
I only have this profile and the default prosody.cfg.lua

I see, cause in the default config there are 3 places with storage https://github.com/jitsi/jitsi-meet/blob/master/doc/debian/jitsi-meet-prosody/prosody.cfg.lua-jvb.example
Check prosody logs on restart for the version, I had seen in the past situations with both trunk and 0.11 running on same machine …

It’s because I didn’t look at it carefully.
As you said, if you modify all

storage = "memory"

it will work normally. Do you mind if I summarize the following and put it here?

Yep, go for it

OK, I want to contribute more code to jitsi. Is there any way to debug jitsi’s source code locally?

Every component can be run locally and connected to remote deployment. This is how we do it.

I have successfully run prosody, jvb and jicofo locally
but I have the following questions: does the SSL certificate of nginx need to be self signed locally?
Since it is a local operation, there is no public IP, how to call more than 3 people?
Is there a relevant tutorial?

Do you have any contact information for jitsi team?
I come from China.
I want to promote jitsi in China. Do you have any idea of jitsi team?

You can reach the team via the forum or if you want joon the community call that takes place every two weeks, more info on the website.

This is the solution