Monitoring of jitsi-meet

Hello,

I’ve just install a custum implelentation of jitsi-meet and it’s working like a charm on a fresh ubuntu server :slightly_smiling_face:

How can i know the number of current and closed conferences on my server ?

And the number of user connected to each conference ?

Thank

Hi, for this purpose exist videobridge stats exposed as private REST API.
You can read docs here REST API and videobridge statistics

Hi,

I looked at thoses docs, and tried this :

apt-get install videobridge

edit /etc/jitsi/videobridge/sip-communicator.properties and added the lines :
org.jitsi.videobridge.rest.private.jetty.port=8080
org.jitsi.videobridge.STATISTICS_TRANSPORT=colibri
org.jitsi.videobridge.STATISTICS_INTERVAL=1000

service jitsi-videobridge restart

And still nothing on port 8080 :frowning:

nmap localhost
PORT STATE SERVICE
22/tcp open ssh
80/tcp open http
443/tcp open https
4444/tcp open krb524
4445/tcp open upnotifyp
5222/tcp open xmpp-client
5269/tcp open xmpp-server
5280/tcp open xmpp-bosh
8888/tcp open sun-answerbook

No 8080 !

What am i missing ?

Hello,

For activate the monitoring api in jvb =>
In jvb file “config” check this option :

JVB_OPTS="–apis=rest,xmpp"

Hello,

I change the line JVB_OPTS in /etc/jitsi/videobridge/config and restarted jvb and videobridge service

Regards.

Re,

If Onpremise setup :
Check file /etc/jitsi/videobridge/config

If Docker Setup is more complexe but is not impossible :
Show Config in Container

docker exec -it [Contener JVB Name] cat /etc/jitsi/videobridge/config

Hello,

I change the line JVB_OPTS in /etc/jitsi/videobridge/config and restarted jvb and videobridge service.

No response on port 8080 still

Regards.

In your /etc/jitsi/videobridge/sip-communicator.properties
Remove

org.jitsi.videobridge.rest.private.jetty.port=8080

Add

org.jitsi.videobridge.ENABLE_STATISTICS=true

Done.

Was already in file.

Restarted jvb and videobridge service.

No response on port 8080 still.

THANKS FOR YOUR HELP !

Regards.

Please check yours configuration with one provided into REST documentation: https://github.com/jitsi/jitsi-videobridge/blob/master/doc/rest.md

You can publish your config file and log please ?

OK. There was a typo in config.

Now port 8080 is open :slight_smile:

But when i try to access from network, i get
Échec de la connexion sécurisée
Une erreur est survenue pendant une connexion à jitsi.i3s.unice.fr:8080. SSL a reçu un enregistrement qui dépasse la longueur maximale autorisée. Code d’erreur : SSL_ERROR_RX_RECORD_TOO_LONG

I didn’t configure private interface whith ssl
org.jitsi.videobridge.rest.private.jetty.tls.port=-1

Why does it want to do https and not http ?

Regards.

here are my config files

cat /etc/jitsi/videobridge/sip-communicator.properties
org.ice4j.ice.harvest.DISABLE_AWS_HARVESTER=true
org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES=meet-jit-si-turnrelay.jitsi.net:443
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=muc
org.jitsi.videobridge.xmpp.user.shard.HOSTNAME=localhost
org.jitsi.videobridge.xmpp.user.shard.DOMAIN=auth.XXXXXXXX
org.jitsi.videobridge.xmpp.user.shard.USERNAME=jvb
org.jitsi.videobridge.xmpp.user.shard.PASSWORD=XXXXXX
org.jitsi.videobridge.xmpp.user.shard.MUC_JIDS=JvbBrewery@internal.auth.XXXXXX
org.jitsi.videobridge.xmpp.user.shard.MUC_NICKNAME=50d5fb37-ae9b-4787-986a-d33461d9dbee
org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.XXXXXXX/.*
org.jitsi.videobridge.STATISTICS_TRANSPORT=colibri
org.jitsi.videobridge.STATISTICS_INTERVAL=1000
org.jitsi.videobridge.rest.private.jetty.tls.port=-1

cat /etc/jitsi/videobridge/config

Jitsi Videobridge settings

sets the XMPP domain (default: none)

JVB_HOSTNAME=XXXXXXXX

sets the hostname of the XMPP server (default: domain if set, localhost otherwise)

JVB_HOST=

sets the port of the XMPP server (default: 5275)

JVB_PORT=5347

sets the shared secret used to authenticate to the XMPP server

JVB_SECRET=XXXXXXX

extra options to pass to the JVB daemon

JVB_OPTS="–apis=rest,xmpp"

adds java system props that are passed to jvb (default are for home and logging config file)

JAVA_SYS_PROPS="-Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=videobridge -Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi -Djava.util.logging.config.file=/etc/jitsi/videobridge/logging.properties"

Hi,

Sorry for hijacking this thread, I wrote a netdata plugin specially for grabbing and displaying these jitsi statistics which might be interesting to you.

It is currently a work in progress but I plan to get it merged upstream in netdata later on.

Feedback and comments welcome!

2 Likes

Hi Francois,

I finaly succed with REST setup.

Thanks for your proposition, but the REST statistics are good for me.

Regards.

Hi @balestra
Can you tell us what was wrong in your config, and what finally solved the issue ?
It might help other people who fall in the same traps and find this topic using their favorite search engine. :wink:

HI,

I installed the jitsi-videobridge packet on ubuntu. It crached the original installation with jitsi-videobridge2 packet.

I rolled back to previous snapshot and the configuration described in this thread worked fine.

Regards.

We already composed the TIG stack on top of docker for jitsi video bridge monitoring. Hopefully, it will be useful. Enjoy…

1 Like

/usr/libexec/netdata/python.d/ don’t exist in Ubuntu 18.04.4 …

directory to use?

You have to first install the netdata agent from https://app.netdata.cloud/