[modules/RTC/BridgeChannel.js] <l._send>: Bridge Channel send: no opened channel

Hi, thank you for your replay
yes, it is the same, if I connect my laptop and my cellphone with wifi its ok, nevertheless without wifi in my cellphone or any friends laptop on a different network, stop the video and the sound :S,
I have tried all that I sow in the forums

STUN_MAPPING_HARVESTER_ADDRESSES should be enabled in /etc/jitsi/videobridge/sip-communicator.properties

yes, I add these two lines
but still not working :frowning:

It seems that the external participants can’t find your public Internet IP used by JVB or UDP/10000 is not accessible for them

@ariza394 to add a little bit to what @emrah advises, make sure that port 10000 is UDP (not TCP) AND that it is properly forwarded in your router. Making sure it’s not blocked by a firewall is one step, the other is to make sure it’s definitely properly forwarded.

Also, make sure you comment out the existing STUN mapping:


And lastly, even though this may be redundant to mention, make sure you’re actually adding those mapping addresses in the videobridge sip communicator properties, NOT jicofo sip communicator properties.

I did the test with ngrep -q ‘is accessable’ udp port 10000, and it receive a petition from the other server, then I think that port is working :S

I install again, after open the ports that emrah told me, now it is working, really thank you so much guys for your time, that was so kind

@Freddie, sorry for calling you in, but do you know if these settings interfere?
I have the same error as the original poster.

This is what I got after configuring everything in the .env and yml files… should I change it after deployment?

To be more precise, I don’t quite understand what causes the error

Hey, no problem.

Try deleting the TCP_HARVESTER_PORT and see if that helps.

as far as I know, if you have disabled tcp_harvester (as you should, see tcp.md in the jitsi-videobridge2 documentation) the port that you ‘set’ has absolutely no meaning and is ignored. If it’s enabled, it’s an input port.

The Stun_mapping_harvester_addresses points to an external server, so it’s an output port, and is used by the bridge to learn it’s public address.
Basically the bridge connects to the stun server on port 443, from this connection the stun server knows the public IP from where the connection originates and then gives back the information to the caller. If your server is not behind NAT the Stun server is useless of course.

So In a word, that these 2 values are the same (443) does not matter at all.

Dear All,
I would like to reopen this discussion again. I got the same error but for sure it is not deal to the JVB setting.
I have a working jitsi having no such error message in the console. Then I download the example code “example.js” from the lib-jitsi-meet. I use this compact code to join the same room as with the full code of jitsi-meet. And the error “[modules/RTC/BridgeChannel.js] <l._send>: Bridge Channel send: no opened channel” shows up on the console of the compact code only. But the participants can still join the conference normally.
It seems to me that
1- the error is not crucial, isn,t it ? (because the participants see one another).
2- and the error happens because of some missing in config / code of the jitsi-meet
Would you please confirm the above. For the second deduction, where can I check for the possible missing part ?
Many thanks for your help

1 Like

It is, no data channel the bridge means you will always see 180p video.

You can check FAQ · Jitsi Meet Handbook it contains the jvb websocket part.

1 Like

Dear Damencho,
I try to follow the link you sent to me. But I show immediately some differences in my system as the following:
-The nginx already listens to the port 443 instead of 4444
-there is no directory modules_enabled in the /etc/nginx
The jitsi-meet was installed about 1 year ago, and updated recently
ii jitsi-meet 2.0.5390-3 all WebRTC JavaScript video conferences
ii jitsi-meet-prosody 1.0.4628-1 all Prosody configuration for Jitsi Meet
ii jitsi-meet-web 1.0.4628-1 all WebRTC JavaScript video conferences
ii jitsi-meet-web-config 1.0.4628-1 all Configuration for web serving of Jitsi Meet
ii jitsi-videobridge2 2.1-416-g2f43d1b4-1

So how can I proceed with procedure?
Websocket nowadays is used JVB communication with jicofo, the MUC (and / or XMPP) is nolonger used, isn’t it? Can you give me a link explaining these protocols used for which purpose within Jitsi please? I just get mess with them all.
Many thanks

Nope, the muc still exist and is the way jicofo discovers jvbs. The websocket is direct connection from clients to the bridge in parallel to the media one.
Make sure websockets are enabled in jvb and you have the nginx config for forwarding that connection as described in the doc.

1 Like

Hi, I am facing this issue I am unable to do meeting with more than 2 participants when third ones join audio and video goes it does not work. What to do then ?

Search for UDP/10000 in the forum

Not get any solution worked for me

You may try jitsi-base installer

I resolved this issue. I am missing to forward the UDP/10000 under firewall rules.Thanks for Your Help.

1 Like

So, in essence, what you were repeatedly told but you insisted you had already done. Glad you finally did it.