Moderation by a single participant

Hi,

In our setup of jitsi for online classes, the default behaviour is that the first to join is the moderator. Children after two weeks of online jitsi meetings have found the joy of moderation. Which means they join in before the teacher and them play with moderation controls in-class. The teachers are not happy.

I am wondering what’s the best solution for this which doesn’t involve a complex setup. My current thoughts is to have “special” nicknames that when join a meeting, get moderation controls and all the others already in the meeting lose them. This would allow the teachers to join with those predefined nicknames and get moderation controls whenever they join.

Is there an easy way to set this up?

Kind regards,

Paulo Matos

Did you try configuring secure domain?

Nope - what do you mean by secure domain? With password to join?
Any type of password would not work with 6 years old. We need something the students just click on something and they are in (that’s a bookmark on their browser). If they suddenly need to input a password, it becomes a nightmare.

@pmatos with Secure Domain, the students don’t need to enter a password, they just won’t be able to start the meeting until the moderator ‘arrives’. If they click on the meeting link before the moderator is in the room, they will get a prompt telling them to wait for the moderator. This is definitely your best option. You wouldn’t want 6yr olds fiddling in an online room by themselves without some adult supervision anyway.

1 Like

Set-up Secure Domain so kids can come early and they will get a message stating that they are waiting for the host to enter, also this enables teacher to refresh the page and still be admin if they open it back up, it’s a very simple set-up

1 Like

Hello @pmatos
We had exactly the same issue and we developed a gatekeeper, who is organising the jitsi-meet conferences. we made the jitsi-admin open source and even the hosted platform for free.
https://jitsi-admin.de
After you add your own server to your account, you can just set up conferences and enter them via your dashboard. other participants like students can be invited via the platform.
When you enter the meeting via the platform, you as the organizer are always set as moderator and the meetings can not be hijacked.

Just try it out : H2 invent - Beratung & Software | Post | Jitsi Meeting erstellen | Deutsch
I hope I can help you.

Dear all,
I have configured a secure domain.
The first connected (the host) must fill in the credentials and he is naturally the moderator.
The second connected can see a pop-up which tells him that the system gives him the rights of moderator!
Thus the second connected also become moderators like the first.
Is there an option to enable in / usr / share / jitsi-meet interface_config.js file or in /usr/share/jitsi-meet-web-config/config.js file?
or is there something else to do while setting up the secure domain?
I’m on debian.

Thanks a lot for your help.
Regards,
Christophe.

Did you set the guest domain in your config.js?

Option to enable what?

to disabled the automatic assignment of moderator role to guests (people who connect after the first).

Let’s say host is A and participant who joins next is B.
When B joins what you see, at B, is a message “Moderator rights granted to A”, “A joined the meeting”

This is expected. B will not be host. Do you see an asterisk below B’s name, like you see below A’s name? If not, then B is not a moderator.

And also as already asked by @Freddie, did you configure the guest domain? If so, guests do not need to login using userid and password. Only host needs to.

Hi Freddie,

No I did not. what I understood is that you only have to modify config.js if the distribution is not Debian. I misunderstand ?

This is what I did by following the guide

/etc/prosody/conf.avail/test.askawi.com.cfg.lua:

VirtualHost "test.askawi.com"
	-- enabled = false -- Remove this line to enable this host
	authentication = "internal_hashed"

and after this block:

 VirtualHost "guest.test.askawi.com"
     authentication = "anonymous"
     c2s_require_encryption = false

/etc/jitsi/meet/test.askawi.com-config.js:

var config = {
	// Connection
	//

	hosts: {
		// XMPP domain.
		domain: 'test.askawi.com',

		// When using authentication, domain for guest users.
		anonymousdomain: 'guest.test.askawi.com',

/etc/jitsi/jicofo/sip-communicator.properties:

 org.jitsi.jicofo.auth.URL=XMPP:test.askawi.com
 org.jitsi.jicofo.auth.URL=EXT_JWT:test.askawi.com
 org.jitsi.jicofo.auth.DISABLE_AUTOLOGIN = true
 org.jitsi.jicofo.BRIDGE_MUC=JvbBrewery@internal.auth.test.askawi.com

Are you using both secure domain and JWT?

Hi Prashanth,

I misunderstood and misinterpreted the popup.
You’re absolutely right. The behavior is right.
I did a test again this evening and I confirm that the behavior is right.
What misled me were the menus : the moderator and the guest have exactly the same menus.
Hence a new question: how to customize the menu of the moderator on the one hand and of the guests on the other hand?

Thanks a lot.

Hi Freddie,
I’m just using a secure domain. My bad. I deleted the line JWT.
Another question : with the Debian distribution, what is the best way to proceed: use the file /etc/jitsi/meet/test.askawi.com-config.js or the file /usr/share/jitsi-meet-web-config/config. js?
What’s your advice?

Thanks,
Christophe.

This doesn’t sound right. Moderator should have few extra options like recording, live streaming…

Dear Prashanth,

For example, when I am logged in as a guest, I can turn off everyone’s microphone, I can turn off everyone’s microphone, I can control security (password and E2EE): these 3 menus are displayed.

In my mind these 3 menus are typically menus that should be moderator menus.

the “toolbarButtons: [” block in the file usr / share / jitsi-meet-web-config / config.js has no effect on the menu?!
the “toolbarButtons: [” block in the etc / jitsi / meet / test.askawi.com-config.js file controls each menu (moderator and guest).

How to control the guest menu without touching the moderator menu?

Thanks.
Regards.
Christophe.

This shouldn’t be the case either. Do you login using user/password for other users too, besides host?
If yes, refer my earlier reply about guest login.

Note that this should be after all components of previous VirtualHost…in other words, it should be just before the next VirtualHost…