Mobile Jitsi cannot go into own jitsi meet server

Hi, did quick installed welcome page showed on URL, but when use mobile jitsi client to room, failed to joint with many retried ,
Ububtu18.04.4 LTS, Jitsi Meet, Nginx with NoIP ddns service
all ports are forwarded
Please help

What is your server certificate? If it is self signed certificate it doesn’t work with self signed replace it with letsencryp

Hi Thanks for reply
I think it is self signed cert, how to replace it with what you suggested here, and what and where i can get some instruction, I am new to ubuntu and terminal command lines…
And how to check if the server is runing and use what command line to start the server
Many thanks for your time

It seems like i dd used the right certificate, I tried to install it and it showed its response
Please see the following:

mchan@vmeet:~$ sudo /usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh
[sudo] password for mchan:

This script will:

  • Need a working DNS record pointing to this machine(for domain vmeet.ddns.net)
  • Download certbot-auto from https://dl.eff.org to /usr/local/sbin
  • Install additional dependencies in order to request Let’s Encrypt certificate
  • If running with jetty serving web content, will stop Jitsi Videobridge
  • Configure and reload nginx or apache2, whichever is used
  • Configure the coturn server to use Let’s Encrypt certificate and add required deploy hooks
  • Add command in weekly cron job to renew certificates regularly

You need to agree to the ACME server’s Subscriber Agreement (https://letsencrypt.org/documents/LE-SA-v1.1.1-August-1-2016.pdf)
by providing an email address for important account notifications
Enter your email and press [ENTER]: tymichaelchan@gmail.com
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Cert not yet due for renewal
Keeping the existing certificate


Certificate not yet due for renewal; no action taken.


Configuring nginx
Pl

Is your sever is public or in a local network and your server is based on public domain name or ip ? If it’s in local network let’s encrypt need public domain name.

the server is located behind router, and it is linked with dynamic dns hosting services with NOIP, the update client is installed and when you enter the vmeet.ddns.net at the url, the home page showed up

Reinstall it maybe it will solve your problem.
Check this link too

How and where I can get the steps to do that?
Also please see the following out put when I tried to launch the Jisti Meet Server
The video bridge seems not runing without “OK”

mchan@vmeet:~ sudo systemctl start vmeet [sudo] password for mchan: Failed to start vmeet.service: Unit vmeet.service not found. mchan@vmeet:~ /etc/init.d/prosody start
[ ok ] Starting prosody (via systemctl): prosody.service.
mchan@vmeet:~ /etc/init.d/jicofo start [ ok ] Starting jicofo (via systemctl): jicofo.service. mchan@vmeet:~ /etc/init.d/jitsi-videobridge start
bash: /etc/init.d/jitsi-videobridge: No such file or directory
mchan@vmeet:~ sleep 25 mchan@vmeet:~ /etc/init.d/prosody restart
[ ok ] Restarting prosody (via systemctl): prosody.service.
mchan@vmeet:~ sleep 5 mchan@vmeet:~ /etc/init.d/jicofo restart
[ ok ] Restarting jicofo (via systemctl): jicofo.service.
mchan@vmeet:~ sleep 5 mchan@vmeet:~ /etc/init.d/jitsi-videobridge restart

Restart your JVB
Service prosody restart
Service jitsi-videobridge restart
Service jicofo restart

Check this link

Hi morning from Canada
What command line for purge old installation and then do this clean installation
the purpose of this installation is to set up a jitsi meet server at a senior care home for residents in the building to send invite to family members in different area using android or ios, the current box is the first and there will be many of the same in the same building for each floor to allow 260 residents for this , thank you for your help and looking forward to your help.
stay sfae and thanks again

Hi Adras
What is the command lines for starting the service
Do I need to purge the ld installed jitsi Meet and reinstall it,
What is the command line to purge the old installation files.
Thanks

Hi Damencho
Hi from Canada
I followed this link and installed the server, but have issues for mobile jitsi enter to room the message stated something wrong will rejoint but cannot,
The server is hosted behind a router and the host name is binded with noip ddns service, however, when I used noip port check service, the most important ports cannot pass through, I double checked the router setting and all the required ports are ported according to the server requirement.
please let me know where I did wrong and if to install again should i purge the old installation first.
Ialso followed the instruction at the early part of the install, here are the output of the process: ----
mchan@vmeet:~ sudo apt-add-repository universe [sudo] password for mchan: 'universe' distribution component is already enabled for all sources. mchan@vmeet:~ /etc/hostname
bash: /etc/hostname: Permission denied
mchan@vmeet:~$ sudo /etc/hostname
sudo: /etc/hostname: command not found

If use auto remove what is the name of the pkg I should put in for auto remove?
I got in the etc file of host
edited as suggested:
127.0.0.1 localhost
127.0.0.1 vmeet.ddns.net

The following lines are desirable for IPv6 capable hosts

::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

Are you using a valid certificate with fullchain provided?

yes, according to the output of letsencry
by providing an email address for important account notifications
Enter your email and press [ENTER]: tymichaelchan@gmail.com
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Cert not yet due for renewal
Keeping the existing certificate
Also ufw firewall status showed all ports as follow:
mchan@vmeet:~$ sudo ufw status
Status: active

To Action From


443/tcp ALLOW Anywhere
80/tcp ALLOW Anywhere
22/tcp ALLOW Anywhere # open access openssh port 22
Nginx HTTP ALLOW Anywhere
OpenSSH ALLOW Anywhere
10000:20000/udp ALLOW Anywhere
443/tcp (v6) ALLOW Anywhere (v6)
80/tcp (v6) ALLOW Anywhere (v6)
22/tcp (v6) ALLOW Anywhere (v6) # open access openssh port 22
Nginx HTTP (v6) ALLOW Anywhere (v6)
OpenSSH (v6) ALLOW Anywhere (v6)
10000:20000/udp (v6) ALLOW Anywhere (v6)

I cannot seem to be able to edit the follow:
The following extra lines need to be added to the file /etc/jitsi/videobridge/sip-communicator.properties
I cannot have access to that and how to locate such file as output from terminal stated the following:
mchan@vmeet:~ sudo /etc/jitsi/videobridge/sip-communicator.properties sudo: /etc/jitsi/videobridge/sip-communicator.properties: command not found mchan@vmeet:~ /etc/jitsi/videobridge/sip-communicator.properties
bash: /etc/jitsi/videobridge/sip-communicator.properties: Permission denied

Also installed videobridge advance and edit theDefaultlimitnofile and follow the check here are the output:
jitsi-videobridge2.service - Jitsi Videobridge
Loaded: loaded (/lib/systemd/system/jitsi-videobridge2.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Tue 2020-04-14 21:33:18 PDT; 40s ago
Process: 20159 ExecStartPost=/bin/bash -c echo $MAINPID > /var/run/jitsi-videobridge/jitsi-videobridge.pid (code=exited, status=0/SUCCESS)
Process: 20158 ExecStart=/bin/bash -c exec /usr/share/jitsi-videobridge/jvb.sh --host=$${JVB_HOST:-localhost} --domain=${JVB_HOSTNAME} --p
Main PID: 20158 (code=exited, status=1/FAILURE)

Apr 14 21:33:17 vmeet systemd[1]: Starting Jitsi Videobridge…
Apr 14 21:33:17 vmeet systemd[1]: Started Jitsi Videobridge.
Apr 14 21:33:18 vmeet systemd[1]: jitsi-videobridge2.service: Main process exited, code=exited, status=1/FAILURE
Apr 14 21:33:18 vmeet systemd[1]: jitsi-videobridge2.service: Failed with result ‘exit-code’.
~
~
it stated failed and not seeing the output as suggested

rg.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=<Local.IP.Address>
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=<Public.IP.Address>
org.ice4j.ice.harvest.DISABLE_AWS_HARVESTER=true
org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES=vmeet.ddns.net:10000,vmeet.ddns.net:20000
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=muc
org.jitsi.videobridge.xmpp.user.shard.HOSTNAME=localhost
org.jitsi.videobridge.xmpp.user.shard.DOMAIN=auth.vmeet.ddns.net
org.jitsi.videobridge.xmpp.user.shard.USERNAME=jvb
org.jitsi.videobridge.xmpp.user.shard.PASSWORD=Xy2n6N0J
org.jitsi.videobridge.xmpp.user.shard.MUC_JIDS=JvbBrewery@internal.auth.vmeet.ddns.net
org.jitsi.videobridge.xmpp.user.shard.MUC_NICKNAME=ca72d4a3-09dd-44c2-a9b6-106a7ddc8016

Questions:
Reading this (MUC_JIDS= the email address JvbBrewery@internal.auth.vmeet.ddns.net (Do I need to change that to my email address?
User shard domain " user.shard.DOMAIN=auth.vmeet.ddns.net " here do I need to change that ?

Hi After restart prosody and check status
here is the out put, it seems to me that the ports are not functioning with it
mchan@vmeet:~$ sudo service prosody status
● prosody.service - LSB: Prosody XMPP Server
Loaded: loaded (/etc/init.d/prosody; generated)
Active: active (running) since Wed 2020-04-15 07:06:53 PDT; 28s ago
Docs: man:systemd-sysv-generator(8)
Process: 25633 ExecStop=/etc/init.d/prosody stop (code=exited, status=0/SUCCES
Process: 25638 ExecStart=/etc/init.d/prosody start (code=exited, status=0/SUCC
Tasks: 1 (limit: 65000)
CGroup: /system.slice/prosody.service
└─25650 lua5.1 /usr/bin/prosody

Apr 15 07:06:52 vmeet systemd[1]: prosody.service: Failed to set pids.max: Inval
Apr 15 07:06:52 vmeet systemd[1]: Starting LSB: Prosody XMPP Server…
Apr 15 07:06:52 vmeet prosody[25638]: * Starting Prosody XMPP Server prosody
Apr 15 07:06:53 vmeet prosody[25638]: …done.
Apr 15 07:06:53 vmeet systemd[1]: Started LSB: Prosody XMPP Server.
Apr 15 07:06:53 vmeet prosody[25650]: portmanager: Error binding encrypted port
Apr 15 07:06:53 vmeet prosody[25650]: portmanager: Error binding encrypted port
lines 1-17/17 (END)

After restart Videobridge service here is the output, and it stated service not found:
mchan@vmeet:~ sudo service jitsi-videobridge restart [sudo] password for mchan: Failed to restart jitsi-videobridge.service: Unit jitsi-videobridge.service not found. mchan@vmeet:~