Missing strophe-plugins (disco plugin is required)!

I was trying to buid lib-jitsi-meet on react native. My app was actually working but was not able to get local streams. And suddenly i started getting an error: “Missing strophe-plugins(disco plugin is required)!”.
I have npm installed strophejs-plugin-disco.
Package.json entry is as follows:
“strophejs-plugin-disco”: “0.0.2”

Link to my git repo: https://github.com/mayur-bhandari/libjitsimeet

Can you tell me what i am doing wrong?

So, i was able to solve this error just now. The thing is strophejs-plugin-disco was present in package.json file of lib-jitsi-meet(which is in node_modules of my project). But it was not present in node_modules of lib-jitsi-meet folder(which is in node_modules of my project). I did npm install inside lib-jitsi-meet folder(which is in node_modules of my project).
I installed strophejs-plugin-disco in my project i.e(in package.json of root folder of my app). Which did not work.