Missing mod_storage_memory.lua and other issues after Quick Install

After some days I’m still not able to start meetings with audio or video. Installation was done on a Strato V-Server with 4 CPUs and 8 GB RAM. OS is Debian 9. Only difference from Quick Install was that I did nginx (full) and certbot installation and certificate creation in advance, because script did not work.

In the beginning I wasn’t even able to connect to a meeting and start a chat. I could start same meeting name on different clients but could not see each other and not even my own chat input. I realized that I need systemd settings described under “Advanced configuration” even for this.

No I can start meetings, connect from other (desktop) clients and use chat but screen is still dark and I can only see my own video. Connection from Android client does not work at all.

What I found in further investigations is entry in prosody.err that module mod_storage_memory.lua is missing. And therefore maybe more is missing …

Ports are open, no NAT.

Did a new installation on a clean server. This time with Ubuntu 18.04 and completely following the Quick Install instruction. This time all worked, letsencrypt script included.

Now all is working. Only difference to Quick Install is that I need changes in /etc/systemd/system.conf not even for many participants. Without I cannot connect at all.