Missing instructions in quick install : solutions for not working room and for cotrun not listening 4445

Hello,

Many thanks for the work made.

I’ve passed two weeks to make my own jitsi-meet server working. After many issue solved, i can share some usefull informations that should (in my opinion), be added to the quick-install tutorial on GitHub.

On my very first install, i’ve made a mistake when entering the FQDN of my server. then i followed the instructions given on the tuto to uninstall completely and try a new fresh install. It never worked (about 10 retries without success).

At this time, jitsi-meet was not working at all: a room can be opened but no control was working (even the room quit button was not working). A clue: the file “/etc/prosody/prosody.cfg.lua” had only 3 lines in it.

The solution was to purge prosody. This purge should be added to the quick install tuto to avoid the same problem on others install.

Now i am still confused by the role of coturn server with is not well explained neither in quick install tuto nor in manual install tuto.

The fact is the coturn server does not listen on it’s TLS port (port 4445 for now), when it is installed by jitsi-meet and when letsencryp certificates are used. I think that merely 99% of jitsi-meet personal servers are using letsencrypt certificates so this is a big issue.

I’ve found the reasons after several hours of searching: the coturn service does not run as root but as user “turnserver”. The letsencrypt certificates and all the letsencrypt tree belongs to user “root” and group “root”. The corturn user does not have the right to read the certificate private key so it does not listen on it’s TLS port.

The solution i successfully tested is:

  • change the group for the entire “/etc/letsencrypt” tree to the already existing “ssl-cert” group ;
  • add “turnserver” user to the “ssl-cert” group ;
  • restart the turnserver: systemctl retsart coturn.service

I had bad times when i was trying to figure out what was the problem because the jitsi-meet coturn configuration file does not contain instructions for a log file. To fix this and the future issue linked to coturn, the next operations have to be made in order to give coturn a log file:

  • Add the line “log-file=/var/log/coturn.log” in the file “/etc/coturn.conf” ;
  • restart the turn server: systemctl retsart coturn.service ;
  • Create a log rotation config file: “/etc/logrotate.d/coturn” with a minimal content:
    /var/log/coturn/coturn.log {
    size 100k
    missingok
    rotate 5
    compress
    delaycompress
    notifempty
    copytruncate
    }

There are also missing log rotations instruction for the jvb log witch grow very fast (about 100 MiB in one week). I did not found any setting to block jvb sending a big amount of useless data into it.

I hope this will help.

2 Likes

I found that using htop on an ubuntu server was very useful for identifying and killing all processes. That was how I discovered that apt purge does not kill processes and that prosody and coturn were running.