Missing features for Jigasi on latest docker-jitsi-meet

Hello everyone,

First of all, as a newcomer, I want to congratulate you for this outstanding project and also thank you for all the work you put into it.

Now, I have been playing with the latest docker versions of jitsi, and after a bit of effort, I have managed to get all the features to work, including jibri. I have also integrated the jigasi transcriptions into my current deployment and it seems to work well. However, there are two important features related to the transcriptions that don’t seem to work currently and I would like to know if I am missing something or if they have not been implemented yet in the latest stable versions.

  1. The first issue is that it does not seem possible to hide the jigasi transcription user through the hiddenDomain. I’ve tried all possible combinations in the .env file, with and without authentication and allowing guests, using the recorder domain, etc. without success.
  2. The second issue is that the toggleSubtitles function from the IFrami API does not seem to work, which means that the user needs to manually trigger the subtitles.

Am I missing something or are these features not implemented yet in the latest docker releases?

@damencho do you know if we need extra config for those?

You need enable auth with no guest

And that domain to be in hidden domain

If you have jibri you create jigasi user in the recording domain.

Hi @damencho. Thanks a lot! Indeed, with the following configuration:


it seems to work. However, I’m stuck with the authentication mode, which is kind of distracting at the moment. It might be useful at a later point, though.

Regarding the second point about the automatic triggering of the transcriptions, is there currently a way to start it without any manual interaction from an user?

What do you mean?

Nope, there is no such feature. So you say that using toggleSubtitles through iframeAPI after you join the conference and receive the event that you are a moderator in the meeting does not work?

I was currently not using authentication to create new rooms, but rather automatically protecting the new rooms with a password through the IFrame API. I could then manage the passwords externally and input them automatically through the IFrame API as well, so that the entire process is fully transparent to the user.

With the authentication, jitsi now requires the user to provide the corresponding credentials before entering the session, which I will try to handle as well, in order to keep the whole process transparent to the user. I still need to explore all the possibilities that are provided through the authentication option (JWT, LDAP, etc), but it might be useful for my particular use case in the future. Anyway, I have no choice but to enable authentication, since it’s required in order to hide the transcription user.

Regarding the toggleSubtitles function, yes, it does not seem to work for me, as the command is not recognized (I get a “Not supported command name” error). I do exactly as you say, calling the toggleSubtitles command just after receiving the event “participantRoleChanged” with the role “moderator”. The setSubtitles command does not work for me either, btw. I was surprised by this, because I did not have any isue with any other commands.

Again, thanks a lot for all your feedback!

You can disable authentication and use a custom jigasi config to add just:

org.jitsi.jigasi.xmpp.acc.USER_ID=jigasi@{{ $XMPP_RECORDER_DOMAIN }}

And you need to create that user in prosody for that domain.

Which version of jitsi-meet is that?

Hey @Tamas_Domokos can you check this, is it working?
Maybe we need to also add languages to the iframeAPI…

I’m currently using the stable-7648-3 release, although I’ve tested the latest releases as well.

Regarding the custom jigasi config, that sounds interesting. Can I ask you what is exactly the procedure to implement these custom configs using docker-jitsi-meet?

1 Like