Minor Issue with Breakout Rooms: Cannot interact with participant after sending them to a breakout room and they return to the main meeting

I have been testing breakout rooms through https://meet.jit.si/ this morning. I have run into a few bugs but the only one I have been able to recreate consistently is one in which, when a user goes to a breakout room and then returns to the meeting, the moderator can no longer send the user to a breakout room (or do anything with that participant; the three dots next to them no longer opens the menu. Use the following steps to recreate the issue:

  1. Create a new meeting on https://meet.jit.si/
  2. Join the meeting as a moderator
  3. Have someone join as a participant
  4. Open the participants tab
  5. Add a breakout room
  6. Have the moderator send the participant to the breakout room
  7. Have the participant leave the breakout room

Expected Result: The moderator should still be able to click on the three dots next to the participant to Stop Video, Kick Out, send to breakout rooms, etc.
Actual Result: The three dots next to the participant in the participants pane no longer opens the menu

I am new here, so if this is something I should add to Git in stead, please let me know and I will do that (I saw someone else do that with an issue they found and someone responded that they were supposed to post it to the forums first, so that is what I am doing; but I am new here so any advice regarding expected conventions is appreciated).

I will keep testing breakout rooms functionality (as it is something we are very excited to add to our solution) and let you know if I can consistently recreate any of the other issues I have experienced this morning. Thank you.

Yes, this is a known issue and it’s on the radar. Pretty sure a fix is being worked on. Thanks for reporting it also though.

Can you reproduce it on alpha.jitsi.net?

Yes I can reproduce it; I just went through the steps I listed above and this is currently an issue on alpha.jitsi.net as well.

Please let me know if there anything else you need from me regarding this.

Thanks.

FTR I can’t reproduce on my test instance with latest unstable (6705). Can you try with another browser (Chrome if you use Firefox, or Firefox if you use Chrome) ?

I can’t reproduce this on my local instance either (6689) using chrome.
It seems however that camera sometimes (seemingly random) gets enabled when entering/leaving breakout rooms?

It is very strange and not reproducible 100%, it is some stale hover state … we are checking it …

I have seen something that looks like your description (see my thread ‘Breakout bad’) with Chrome 96. Can you try with Chrome 98 - I could not reproduce with this version.

I just tried with Dev Channel / Chrome 98 (98.0.4750) and the issue occured (on a device that didnt have a camera, but an error: the camera cant be used, device not found popped up)

steps taken:
created conference
joined with 2 other tabs (3 participants total)
created breakout room
moved both tabs to breakout room
tab1 left breakoutroom
→ error camera not found on tab1 session

I was able to reproduce this issue on Chrome Version 96.0.4664.45 (64-bit) and Firefox 95.0 (64-bit).

Thanks for the detailed report. Managed to fix it: fix(breakout-rooms) fix non-functional context menu by saghul · Pull Request #10558 · jitsi/jitsi-meet · GitHub