MiniPC with Mic and no Camera will not work with Jitsi Meet

I have a Beelink MiniPC with a microphone that is built into the box but no camera.

I can create a Jitsi Meet discussion and hear everybody invited but no one can hear me because jitsi meet will not work without a camera to go along with the microphone. Meet detects that there is no camera and does not allow the microphone to operate.

Is there any way to use meet with a microphone and no camera?

this is strange I have a PC without cam and the mic works. What’s the problem exactly ? is it that

  • the browser don’t ask for permission at all ? in this case your mic is not recognized by the OS/browser
  • you give permission but the mic is disabled at the jitsi level ?
  • or the mic is enabled but what you say can’t be heard ? if it is the case, can you test the mic out of your browser ?

Anyway, you can turn any Android phone that does not deserve a place in a museum into a webcam. The perf may be terrible but it could display something. Check out IP Webcam or similar software. Theoretically you can also use the phone mic. Never tested it personally as I have better optons, but it could get you something.

The message I get is “Failed to access your camera”
I am running windows 10 1909 and Chomium-based edge.
Clipboard01

I also tried Firefox and Chrome. The mic works with Hangouts and Skype.

If your mic works on test.webrtc.org, you should file an issue
if it does not work on webrtc.org, it’s not fully compatible so the Android phone way could be a good idea.

The mic test worked fine.
[ OK ] Audio track created using device=Default - Microphone (High Definition Audio Device)

[ INFO ] Channel 0 levels: -3.5 dB (peak), -11.4 dB (RMS)

[ INFO ] Channel 1 levels: -3.6 dB (peak), -11.4 dB (RMS)

[ OK ] Active audio input channels: 2

[ INFO ] Stereo microphone detected.

IPv6 reported this: “[ WARN ] Failed to gather IPv6 candidates, it might not be setup/supported on the network.” is that likely to be a cause for mic failure with Meet?

these values seem a bit on the high side (I have much lower values on my systems) but if the webrtc test accept them it should be fine. Maybe try to lower the level, it don’t cost a lot to do this test anyway. But I see nothing strange and an issue seems an idea to me even in the remote possibility that lowering the level could fix it.
I don’t see why Ipv6 could be a problem, can’t see a link.

@PhilipS try going on the locker symbol (left of the url) then allow from there the microphone.

Indeed jitsi ask permission of both microphone and camera in the same permission, while other web based chats make 2 different queries

@damencho maybe this is a possible thing to improve: separate microphone permission from the camera one

The lock left of the URL when clicked shows microphone “allowed” but no one can hear me on meet.jit.si and the microphone symbol is not crossed out at the bottom centre of the jit.si tab.

You’re forgetting to say which browser are you using, if you tried to update your driver and if you tried to use the microphone with other applications, like skype, hangout, telegram or similar.

I did mention that I first tried it with FireFox (current version), then with Chrome (current version) and finally with Microcoft Edge (Chromium based version, also current). All under Windows 10 1909.

The driver for the microphone is also the current version under windows 10.

What about other video conferencing browser based applications?
What about windows app ones?

I also mentioned that the BeeLink MiniPC under windows 10 1909 works fine with Facebook Messenger and web skype on all of the browsers I mentioned; Firefox, Chrome, and Edge.

Skype and facebook uses a client installed support application, did you tried with Google Duo via web?