Mic picking up background noise in self-hosted

I just did a fresh install and accessing it through a mobile browser. It’s picking up background noises from the mic, but on meet.jit.si it’s totally silent on the same scenario.

If your install was really fresh, Meet.jit.si deployment seems to have some option on noise suppression.
But I couldn’t find that option in config.js

I also want to know how to setup noise suppression option.
If you find answer, please share it here.

Anyone can give answer here?

The noise suppression is enabled by default. It can be disabled by setting disableNS in config.js. Check also disableAEC, disableAGC, disableAP, disableHPF

1 Like

Really thank you.
Can you explain simply about AEC, AGC, AP, HPF functions?

And how NS works? in server(algorithm implemented in java)? or webRTC setting(javascript)?
I want to peek into how NS works.

Thanks again :+1:

IIRC

AEC: echo cancelation
AGC: auto gain control
AP: audio processing
HPF: High pass filter

Everything is in the client, implementation in the browser.

1 Like

Then maybe @Albert_Cruz is deploying old version jitsi?

Yes. I did this over a week ago and just noticed the echo recently. I updated everything to the latest version and echo is now gone

Congratulations!