Mic can't be unmuted during screensharing

There was some problem with a microphone when you turn on screen sharing.

Steps for reproduce:

  1. Create conference and join there with 2 users or more.
  2. Connect to this conference with the disabled mic.
  3. Press the ‘screen-sharing’ button and start to share browser tab.

A user who started screen sharing will be unmuted and other users can’t hear him.
If the user presses mute and unmute in the conference, it doesn’t help.
Help only if open popup with audio setting and select microphone manually.

Welcome to the forum.

Is this on meet.jit.si or on your private server? I couldn’t reproduce this on meet.jit.si just now.

I reproduced this problem on meet.jit.si right now.
The main point, join to the conference with the muted microphone.
Select the screen sharing tab and the microphone will be unmuted, but no sound.
Pressing the mute/unmute button doesn’t help, the sound will appear after selecting the microphone from settings.

Here link with screen recording:
video

Hello. Did you find the solution?

I couldn’t reproduce this on meet.jit.si. I tried several times - including just now.

I reproduce the problem on meet.jit.si now. If you select Entry screen and window sound work. But with Chrome Tab only silent.

What are the browsers, versions and OS you are testing on?

Ah, I see - only shows up when sharing a tab. Well, you have the “Share audio” option checked by default when you’re sharing a tab. Uncheck it and you won’t have audio unmuted. It’s doing exactly what it’s meant to do.

Hey the issue has been resolved. fix(audio-share): mix newly created audio track with screen audio (#1… · jitsi/jitsi-meet@6068a30 · GitHub