Menu entry "start recording" after update to jitsi-meet 2.0.7577 gone (jibri 8.0-121)

Hello one and all.

After updating to jitsi-meet 2.0.7577 the menu entry “start recording” is suddenly gone. Did not change a thing config-wise. toolbarButtons setting is empty. Both in interface-config.js and in my-domain-config.js. Someone has an idea what’s going on here or should I dig deeper?

cheers, t.

There some minor changes in new config. recordingService is added and fileRecordingsEnabled is deprecated.

Thanks for the answer @emrah but still no luck. Changed this setting and now I have a menu entry named “Noise Supression” (interesting! :)) but still no “Start Recording”. Any other ideas? Thanks again.

Is this a newly installed Jitsi or an upgraded one?

Upgraded from the previous version.

I’m not sure but an upgrade may keep the old config which doesn’t have newly added params.

A fresh installation may be better if you don’t have many customizations.

Thanks again. Is there a clean config.js available for download somewhere? Maybe on github? Could compare both files then.

cheers, t.

Fixed by

    recordingService: {
        // When integrations like dropbox are enabled only that will be shown,
        // by enabling fileRecordingsServiceEnabled, we show both the integrations
        // and the generic recording service (its configuration and storage type
        // depends on jibri configuration)
        enabled: true,
    },

Thanks again!

1 Like

Sorry about that, we try not to break existing configs but missed this one. IIRC the backwards compatibility was restored after the release.

No problem @saghul :slight_smile: I consider myself an early adopter and expecting these kind of things.

1 Like