Meet: Sharing stuff don't go out to YouTube proxy when broadcasting to YouTube

We’ve been using meet to broadcast a weekly webcast for the Greek EV community for a couple of years now (you can find our channel here), broadcasting directly to YouTube through meet. We’ve been using the “share video…” option to broadcast our opening clip as well as to share additional YouTube content to our audience during the show.

However, it’s been a few weeks that something has broken, or you did a change that we haven’t been able to identify yet. When sharing the YouTube video in meet, seems like the YouTube proxy user doesn’t get any video input from YouTube, meaning it doesn’t get through to the broadcast. It used to just default to full-screen video playback up until recently. Here’s the first show that caught us by surprise. You can see how it was working properly by watching most of our older episodes.

I am also noticing that screen sharing from the iOS app, also doesn’t seem to get through to the YouTube proxy.

Any ideas?

Not sure what you mean by YouTube proxy. Can you please share a screenshot of the correct behavior and one of the incorrect one?

Thanks!

afaik, when streaming to YouTube, there’s a YouTube “proxy” user that connects to the conference. The stream gets over to YouTube though this “proxy” participant. At least, that’s how I understand it. It doesn’t make sense to share a screenshot. It’s just that the shared video doesn’t play on YouTube. We could set up a conference any time as a test. Happens every time, at least on my side.

As mentioned above, at this episode it doesn’t work properly. There was no into movie broadcasted to YouTube. Prior episodes have the proper intro video correctly broadcasted.

Ah, I understand the confusion. That’s not what happens :slight_smile: Every participant opens the YouTube video using the YT iframe API and we use some backend commands to sync the playback.

I think I know what the problem is, this has regressed recently, and the video is not displayed when in tile view, but it is when in stage (single participant) mode, right?

Actually, I tried to reproduce it now on meet.jit.si and can’t. This is what I’m doing:

  • Join the meeting with 2 participants
  • One of them shares a YT video
  • The view changes to stage mode even if it was in tile view and the video starts playing

I don’t think we ever rendered the video in tile view, we always switch to the large view.

By “YouTube proxy user” I refer to the dummy user that broadcasts the meeting over to YouTube when you’ve started a live stream. For live broadcasting. Only THEN does the problem occur, and ONLY for the broadcast; all other users in the meeting are experiencing the shared video as expected.

So, to reproduce the issue, you’ll have to follow these steps:

  • join the meeting with minimum 2 participants
  • start broadcasting to YouTube by selecting “start live stream”
  • share a YouTube video on stage
  • the video will not show up on the live stream.

But this is reproducible without jibri(this is the service that broadcast to YouTube). Open two participants on meet.jit.si and share the video from A and B is seeing it in the thumbnail, that is a bug.
Can you open an issue on jitsi-meet project for it?

Hum @saghul I reproduce it on meet.jit.si and I do not see what you have experienced…
For me it stays in tile view …
JIbri is always in stage view.

So, my “fake proxy user” is actually called “jibri”. This is where I should file a bug report then, for the jibri service?

afaik, I agree with saghul, shared videos always play in stage mode, as it should. I don’t see any different behavior on this one; only problem is that the video doesn’t get over to jibri to be broadcasted to youtube.

Ok, hold on, so there might be 2 issues at play.

1- @damencho it doesn’t switch to stage view for you, is that right?
2- Even when in stage view, when Jibri joins the YT video is NOT visible to Jibri, is that right @thanarious ?

Yes. But I’m woth two participants and switched to tile view manually in order to test this scenario

I’m not testing with jibri but with two participants and the video is visible but in thumbnail, but for jibri this is like not visible as it cannot switch automatically.
I know Jaya was looking at it at some point yesterday.

I think I might know then. If you manually select tile view we “respect” your desires. We might need to override that the first time the YT participant joins.

That’s weird it should be pinned to the stage…

I wonder if it has something to do with “filmstrip stage view”…

Yes. The shared video is almost NEVER visible to Jibri, switching between tiled/stage view kind of changes something, but nothing optimal. We also usually have “everybody follows me” turned on, because we want the conference to broadcast only in tile view. But shared videos always used to automatically switch to staged view, for both participants as well as jibri. Jibri is now completely broken. No video. Only audio fyi.

My issue is with YouTube streaming, so jibri is the culprit here for some reason. Please give it a try with that option.

Hum, I just tried it with one participant and 3 participants and jibri on meet.jit.si, and everything is working fine. Showing the shared video on large in all cases…

I don’t know what’s going on here… Just tried with two participants, one desktop and one mobile, streaming to youtube through jibri, shared a video, and while both participants see the video on stage, the stream STILL gets no video. Actually, it seems like the video is playing on the background, because I can see a vertical stripe of it.

So, no, it’s not working on my side. The YouTube stream through jibri doesn’t get a video playback.

… [ten minutes later]…

OK… I think I am getting somewhere… If you don’t have ANY active video streams (i.e. cameras enabled) on ANY participant, then it works fine even on jibri. However, if the participants have cameras enabled, strange things happen over to jibri. See attached image.


This is me from my mobile streaming to youtube, while the shared video is playing at some background layer! The video was shared by the desktop instance.

1 Like

That’s a good finding, thanks for digging in. I will re-do my tests tomorrow, I think I was without any video… But I think this is a known issue that came in after aome refactoring around whiteboard feature, we will be working on a fix. I will confirm tomorrow.